Tribler v7.1.1 is out. Check it out


#1

Dear Tribler Community,

We are very happy to release another release Tribler 7.1.1. This is a minor release which includes several enhancements and bug fixes over Tribler 7.1.0. As always, we would like you to try using this release and give us your valuable feedbacks.

You can download your favorite distribution below:
Windows(64-bit)
Windows (32-bit)
Linux
MacOS

To report any problems, please create a new issue on GitHub or post it on the forum, either in this thread or in a separate thread. If you wish to contribute to Tribler by fixing bugs or adding features, please check out this page which provides basic pointers to get started.

The source code can be found on our Github repository but you can also download it directly here.

Enjoy!


#2

I’m afraid you still have some work to do. When I try to start this version, I receive the following:

Fatal Error!
Failed to execute script run_tribler


#3

@LesVerres Could you specify which distribution are you using?


#4

I’m using Windows 10 64-bit.


#5

@LesVerres does the previous version (Tribler 7.1.0) work for you?


#6

Tribler 7.1.0 worked in the sense that it was always starting without any issues. There was of course the recurring error which I already mentioned in the 7.1.0 thread:

File “TriblerGUI\event_request_manager.py”, line 130, in on_read_data
RuntimeError: [Failure instance: Traceback: <type ‘exceptions.RuntimeError’>: Could not find a number that isn’t in use

Or slight variations on the above.

Although probably unrelated, yesterday I also noticed that the upload/download ratio of some of my torrents had dropped to 0. However, I’m pretty certain that it had been a lot higher before. Strangely enough, this only occurred with some torrents in the list, but not with all of them.


#7

I have the same error as @LesVerres is having and on the same platform as well. For me 7.1.0 was working also, however I did notice that after some time (sometimes several minutes, sometimes several hours) the download speed dropped to 0.


#8

I also have the same “Failed to execute script run_tribler” error after installing v7.1.1

Tribler_7.1.1_x64.exe on Windows 7 64-bit.

v7.1.0 worked fine except for the occasional crash when running for long periods of time and the issue with torrent speeds dropping to zero and then being fine after a Tribler restart.


#9

@LesVerres @watersource67 @krick It seems the problem is with the proxy settings. To fix the issue please remove these two lines from %APPDATA%/.Tribler/triblerd.conf

proxy_server = “”
proxy_auth = “”

They will be recreated with the new configuration setttings.

Please let us know if this fixes the issue for you.


#10

We are investigating this issue and assigned it high priority. Please check out this GitHub issue where we track progress on this bug.


#11

After deleting these lines, Tribler will indeed start again.


#12

Yes, that fixed the issue. Thank you for your help.


#13

image


#14

@mlee Please try the above fix.


#15

Thank you for your reply.
I have been unable to find a file named “triblerd.conf” using the Win 8.1 Search function.


#16

@mlee We just released a new version with the fix. It is available at https://tribler.org
Please try this new version and let us know if it fixes your issue.


#17

triblerd.conf file is located at a folder we call Tribler state directory.
You can find it by typing the following in Windows Run command:
%APPDATA%/.Tribler


#18

I found and edited the file.
Thank you.
Tribler 7.1.1 is loading now.


#19

After removing the two proxy lines and installing 7.1.2 I am able to continue using Tribler again.
Thanks so much