7.4.x GUI issue


#1

Hi all,
The latest updates of tribler after 7.3.0. are having issues with the graphical user interface on my screen. The screen looks like what you see when looking at a high res page or movie in a low res screen, so ony a part of the screen is visible and you need to scroll. I cannot find any settings in tribler to adjust this. So far I have tried all the latest updates (incl. 7.4.4.) but had to revert back to 7.3.0. I am working on a (not so new) W10 powered Lenovo 13" hybrid. The issue is specific to tribler though.
Also, I noticed that all the latest updates change the default download folder and lose any running torrents, forcing to manually retrieve them.
Any ideas, especially on the GUI issue?
Thanks in advance.


#2

Regarding the GUI issue, could you please try this 7.5 alpha build?. Note that you have to backup your Tribler state directory, as this build still does not include a proper state upgrade system.

About upgrading and losing downloads problem: 7.4 is the first branch to be based on Python3. Moving to Python3 required converting all our previous config files, including the download checkpoints (which are essentially configs). To make the upgrade safe for 7.3.x users we implemented a “copy-forward” state directory upgrade system which essentially clones your current config into a new dir, and then runs upgrader procedures on that dir. 7.4.0-2 though shipped with some nasty bugs in the versioned upgrading system, which resulted in people losing their settings.

The upgrader will try to upgrade from the last version that you ran before if its version is less than the currently running version. 7.4.4 is the most stable of the series so far. You can look at this wiki page for more info about fixing upgrade problems.


#3

Thanks for the quick reply!
The 7.5 alpha build did not help re. the GUI issue unfortunately.

I’m struggling a bit with that upgrade part, but that can be because I have been skipping back and forth between the latest builds and 7.3.0, so likely my folders and registry are now a complete mess. I don’t have any critical downloads at the moment, so I might go for an uninstall, do a registry clean and remove any residual tribler folders, and start from scratch. Being more of a basic user of this stuff than someone that dives deep in it, that might be the best way forward :slight_smile:
But I will wait with that until the GUI issue is solved, because only than can I move to a later build.


#4

Could you provide a screenshot of your problem? That will help.


#5

Sure, no problem.


#6

The text in the white search line keeps the correct size, all the rest is enlarged.


#7

Wow! Never seen this before. I’ve created an issue on GitHub.


#8

Thanks!

For what it’s worth, I reinstalled 7.3.0, removed the folders of the newer versions and the json file, then reinstalled 7.4.4. It did find my downloads now without a problem, so that is tackled. I’ll stay on that version now despite the GUI issue, let’s see how that develops.


#9

Could you please try this experimental build I’ve created just now? It has QT resolution autoscaling disabled. We need to check if that solves the problem.


#10

Done, that indeed solves the GUI issue.


#11

Well, that means QT detects DPI of your screen wrongly. Basically, I removed the lines that enable auto-scaling QT interface dependent on the DPI reported by the system. Enabling this lines is critical for people with high-DPI screens, so disabling the scaling by default is no option…

We’ll have to discuss the problem with the team.

Meanwhile, you can try updating your video drivers, updating your Windows build, etc. Tribler is probably not the only QT application to have this problem.


#12

Thanks for the info. My laptop is as up to date as possible, I’ll check manually if I can find some newer drivers. As said, it’s not the newest machine, so that can contribute to the issue. Tribler has been the only program where I have encountered this (so far), if I had seen it on other programs as well I would have looked into the drivers and updates much sooner.