Tribler won’t display a window for me


#1

Recently I switched from a 3 monitor extended desktop setup, to a 2 monitor mirrored setup, since I made the switch tribler won’t launch properly, I am unsure if this is a coincidence or cause of the issue. When I start tribler, it launches, appears in task manager and in the tray of running apps at the bottom of my screen, but there is no window. When I hold alt tab, it appears there is an open tribler window, the window preview is solid white, but I can’t get it to pop up on my desktop and actually display the window. Is it possible switching from intel integrated graphics to amd drivers caused the issue and I need to reset the tribler config to stop attempting to use a graphics driver that is no longer enabled? Or does this seem unrelated? I do not get any crash reports or error messages, just evidence that tribler is running, but no way to view the window. I am using the latest version of windows and amd graphics drivers, please let me know if there is more information I can provide to help solve this issue, thank you :slight_smile: (also I’ve already reinstalled tribler twice and tried running as adminstrator and in compatibility mode for windows 8)


#2

It is completely unrelated.

What you can try is:

  • disable the second monitor, then run Tribler
  • try changing screen resolution for your desktop, then switch back (Windows Display properties).

#3

Thanks for the suggestions! Unfortunately they didn’t have any affect on my situation. I tried multiple resolutions and scaling settings, unplugging cables, disabling monitors, extending, mirroring. So far I feel like I’ve tried everything shy of returning to a three monitor setup (which is no longer an option). Is there anyway to completely delete all tribler data and settings, both in the eyes of windows, and tribler, to start over?


#4

I thought window position should be reset if you close and open an application, but if that is really the problem then maybe you can try moving it with keyboard shortcuts. I found this page after a quick search: https://www.minitool.com/news/move-window-with-keyboard.html


#5

Tribler keeps its config in two places:

  • the Core, channels, torrents database is in the Tribler config dir, which is stored in
    %APPDATA%\.Tribler or %APPDATA%\roaming\.Tribler, e.g. c:\Users\vasyliy_pupkin\roaming\.Tribler
  • the GUI settings are stored in the Windows Registry, under the HKEY_CURRENT_USER\Software\nl.tudelf.tribler key.

I’d start from deleting the HKEY_CURRENT_USER\Software\nl.tudelf.tribler with regedit. If that does not help, I’d search for tribler string all over the Windows registry and delete every trace of it. If that does not help, I’d delete/rename the Core config dir (the one in %APPDATA).