Tribler crashes (Manjaro Linux) [solved]


#1

Hi there,

I have here a Manjaro Linux with Kernel 5.9.16, Python 3.9,1 and Tribler 7.6.1-1

After starting Tribler, I got a crash with the following:

Traceback (most recent call last):
File “/opt/Tribler/run_tribler.py”, line 12, in
from tribler_core.config.tribler_config import CONFIG_FILENAME
File “/opt/Tribler/tribler-core/tribler_core/config/tribler_config.py”, line 9, in
from validate import Validator
ModuleNotFoundError: No module named ‘validate’

Any idea how to fix this? Thank you.


#2

Did you install from source? In that case, you should have installed all the dependencies. For this one, try pip install validate.


#3

I installed Tribler from an AUR. Validate seems to be the problem.

pip install validate has the following output:

Using cached validate-1.0.1.tar.gz (32 kB)
ERROR: Command errored out with exit status 1:
command: /usr/bin/python -c ‘import sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/tmp/pip-install-izpoyjie/validate/setup.py’"’"’; file=’"’"’/tmp/pip-install-izpoyjie/validate/setup.py’"’"’;f=getattr(tokenize, ‘"’"‘open’"’"’, open)(file);code=f.read().replace(’"’"’\r\n’"’"’, ‘"’"’\n’"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ egg_info --egg-base /tmp/pip-pip-egg-info-b3qlenx5
cwd: /tmp/pip-install-izpoyjie/validate/
Complete output (8 lines):
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-install-izpoyjie/validate/setup.py”, line 13, in
from configobj import version as VERSION
File “/tmp/pip-install-izpoyjie/validate/configobj.py”, line 1632
except Exception, e:
^
SyntaxError: invalid syntax
----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.

Any ideas?


#4

Got it…there were two different versions of configobj installed. Removed both and installed that from requirements.txt - now it works :star_struck: