Tribler 7.3.0-RC3 is out!

Dear Tribler Community,

Tribler 7.3.0-RC3 is available today with several fixes and improvement over the 7.3.0 RC2 and an important update to Trust graph. We would like you to try it out and give us feedback. For upgrade from stable version, everything should work fine. Since it is a pre-release version, we suggest keeping a backup of your state directory before trying out this release.

The binaries are available below or can be downloaded from the official release page at Github repository.
Windows (32-bit)

If you encounter any problems using this release, feel free to report back to us. We’ll appreciate that. You can either create an issue ticket in Github (link here) or simply post it here in this forum.

For developers willing to contribute to Tribler with bug fixes or new features please check out this page which provides the basic pointers to get started.

And as always, the source code can be found on our Github repository but you can also download it directly here.

We hope you enjoy using this version.

ubuntu19.04, same error as before…

Traceback (most recent call last):
File “/usr/share/tribler/TriblerGUI/”, line 136, in
self.reply.error.connect(lambda error: self.on_error(error, reschedule_on_err=reschedule_on_err))
File “/usr/share/tribler/TriblerGUI/”, line 81, in on_error
raise RuntimeError(“Could not connect with the Tribler Core within 60 seconds”)
RuntimeError: Could not connect with the Tribler Core within 60 seconds

@cisf Could be that some dependency is missing. Does RC2 work for you?
In RC3, we added a new dependency python-pyqtgraph.

RC2 same error ;

pip install pyqtgraph
Requirement already satisfied: pyqtgraph in /usr/lib/python2.7/dist-packages (0.10.0)

Just downloaded the new 7.3.0
Appears to have deleted all my files. or rather, they are showing 0%
While I waited for it to load, forgot to get straight back, it started re downloading those I had from scratch.
It’s weird coz I renamed the Tribler downloads folder before getting new 7.3, yet now I have two Tribler downloads folders. and files empty or broken. *
and I’m at -909.+ GB

*LATER…-ok, after starting a check, some are still ok but I cant see a pattern yet. So far some movie files part play before stopping. Some seen ok but haven’t watched 100% of them yet. Many don’t start, and all show as empty. I’m talking of music and movie files and playing on VLC.

(stopped the old files re -downloading this morning, however, neg token has grown -2gb since then, over 5+ hours, … anyone else? big numbers after the (0)___ but not much else happening.

-Do huge neg token equal Tribler system slowing please?

  • if for example, I download 3 x 1GB files, how many -tokens does that equal? 3GB? or more?
    -if for example I don’t download over 24hours, just leave open to share, will I use tokens? will I use anything at all? (Sorry, if that’s too obvious to others perhaps you could refer me to somewhere that explain it.)

Thank you again for your Tribler and Tribler help.

-and enjoy

Sadly Tribler ignores those pip installs sometimes. Workaround and fix on my Ubuntu 18.04.3 LTS machine is this beastly install fest. All due to the pretty & fast graphics of our trust graph:
sudo apt-get install python-pyqtgraph python-opengl python-qt4 freeglut3 libqtassistantclient4
Your reward is this:

freeglut3 is already the newest version (2.8.1-3).
libqtassistantclient4 is already the newest version (4.6.3-7build1).
python-opengl is already the newest version (3.1.0+dfsg-2).
python-pyqtgraph is already the newest version (0.10.0-1).
python-qt4 is already the newest version (4.12.1+dfsg-2build2).

To be clear, the spining gears appear, after about a minute, the program crashes with the “60 seconds” error. There is no hdd activity or CPU shortage.

This is on a fresh install, both with and without my old ~/.Tribler folder

That is weird, can you check the log file, as shown here.
Then we can see what dependency or other stuff that is going wrong:

…got it working :
1: ImportError: No module named lz4.frame
pip install lz4
2: ImportError: No module named pony
pip install pony

after this it starts, but there is this error in the log : ERROR 1566242231.00 LaunchManyCore:275 (TriblerLaunchMany) bitcoinlib library cannot be loaded: No module named bitcoinlib.wallets

python-cryptography is already the newest version (2.3-1ubuntu2).

will test tomorow if the graphs work.

Maybe more of the dependences can be put in the installer?

thx for the help to get it working !

1 Like

@cisf Good to know that you got it working.

Bitcoinlib is an optional dependency, only needed if you want to use market. The dependency can be installed via:
pip install bitcoinlib

Does Trust Graph work for you?

yep all is well!

1 Like