Tribler 7.10.0-RC3 is out today


#1

Dear Tribler Community,

Today we’re releasing Tribler 7.10.0-RC3. This version includes important anonymity fixes on torrent checking therefore, we’d like you to try out this release and let us know if you encounter any issues. We hope you’ll like it. If no significant issues are reported, we’ll be releasing a stable version soon.

The binaries are available below or can be downloaded from the official release page at Github repository.
Windows(64-bit)
Windows (32-bit)
Linux
MacOS

If you encounter any problems using this release, you can either create an issue ticket in Github (link here) or simply post it here in this forum.

For developers willing to contribute to Tribler with bug fixes or new features please check out this page which provides the basic pointers to get started.

And as always, the source code can be found on our Github repository but you can also download it directly here.

We hope you’ll enjoy using this version.
Cheers!


#2

Tribler 7.10.0-RC2 and Tribler 7.10.0-RC3 both fail to start under Debian 10 on my laptop, but RC1 does. They all work on my desktop running Windows10.


#3

RC2 and RC3 are built on Ubuntu 20.04 which has a higher version of glibc that could be the issue.
Here is the same version built on Ubuntu 18.04, could you try this and let us if it works?
https://jenkins-ci.tribler.org/job/Build-Tribler_release/job/Build-Ubuntu64/297/


#4

Sorry still does not start, but there is a short crash log.
Fatal Python error: Aborted

Current thread 0x00007f569b946740 (most recent call first):
File “tribler_gui/single_application.py”, line 26 in init
File “tribler_gui/tribler_app.py”, line 24 in init
File “run_tribler.py”, line 190 in
I hope this helps.


#5

@speedyme thank you for the log but it is not sufficient to figure out the issue. Python has two processes running, one for the core and the other for GUI. I’d like to know if it is issue with running core or GUI Qt related issue. For that, could you try the following command in terminal to run the core process only?

CORE_BASE_PATH=/usr/share/tribler CORE_API_PORT=8085 CORE_API_KEY=KEY CORE_PROCESS=True /usr/share/tribler/tribler

If it shows some errors, please let us know.


#6

I tried the command, the core seems to run O.K. If you need any other information let me know.


#7

@speedyme Good to know that the core is running fine. The issue should be in GUI and most likely related with PyQt (in my opinion). We’ll need more details to figure out. For that, there are two trace flags --trace-exceptions and --trace-debug which could be useful.

First, please run this command:

/usr/share/tribler/tribler --trace-exceptions

It’ll create a file ~/.Tribler/gui-exceptions.log. This file might include more details about the exceptions.

If the exception file does not include much information, I’d like you to run

/usr/share/tribler/tribler --trace-debug

This will generate ~/.Tribler/gui-debug.log. This will be more verbose.

If you could upload these files here, it will help us to understand the issue more.


#8

I tried those commands but cannot find any logs, they just fail with the following error,
Error loading Python lib ‘/usr/share/tribler/libpython3.8.so.1.0’: dlopen: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29’ not found (required by /usr/share/tribler/libpython3.8.so.1.0)


Tribler 7.10.0 does not start in debian 10
#9

@speedyme thank you trying out the above commands.
I wonder what is the version of glibc installed on your system.

Could paste the output of the following command?

ldd --version

#10

This is a up to date version of Debian 10 and GLIBC is 2.28


#11

@speedyme Could you try this build from Jenkins?
https://jenkins-ci.tribler.org/job/Build-Tribler_release/job/Build-Ubuntu64-18.04/2/

It is build on Ubuntu 18.04 with GLIBC 2.27.


#12

I tried this build but it still fails to start. I also tried running the debug command but it fails due to a problem with Qt.
/usr/share/tribler/tribler --trace-debug

INFO:main:Sentry has been initialised in normal mode
INFO:main:Root state dir: /home/-----/.Tribler
INFO:main:Running in “normal” mode
INFO:tribler_gui:Load logger config: /home/-----/.Tribler
[PID:2489] 2021-07-07 16:31:59,099 - INFO - tribler_core.dependencies(78) - Check for missing dependencies. Scope: both
[PID:2489] 2021-07-07 16:31:59,920 - INFO - tribler_core.check_os(226) - Check and enable code tracing. Process name: “gui”. Log dir: “/home/----/.Tribler”
[PID:2489] 2021-07-07 16:31:59,921 - INFO - tribler_core.check_os(208) - Enable fault handler: “/home/-----/.Tribler”
[PID:2489] 2021-07-07 16:31:59,924 - INFO - tribler_core.check_os(49) - Check environment
[PID:2489] 2021-07-07 16:31:59,927 - INFO - tribler_core.check_os(80) - Should kill other Tribler instances
[PID:2489] 2021-07-07 16:31:59,929 - INFO - tribler_core.check_os(54) - Check free space
[PID:2489] 2021-07-07 16:32:01,880 - INFO - TriblerApplication(23) - Start Tribler application. Win id: “triblerapp”. Sys argv: “[’/usr/share/tribler/tribler’, ‘–trace-debug’]”
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb.

Aborted
The new stable release also fails to run.


#13

@speedyme Could you try this Jenkins build if it works for you?
https://jenkins-ci.tribler.org/job/Build-Tribler_release/job/Build-Ubuntu64/302/

I have tested on a fresh Debian 10 VM and it works there.


#14

Confirmed working, Thanks.