Tribler 7.0.2 wont install on Ubuntu 14.04 LTS


#1

Hi,

I’m trying to install Tribler 7.0.2 on Ubuntu 14.04LTS. If I search on Ubuntu’s own Software Centre the version of Tribler available is 6.2.0 which I presume is old so instead I downloaded the .deb for 7.0.2 and followed the install instructions. The installation fails though due to missing dependencies which are not resolved by apt-get install -f. The following shows the missing dependencies:

dpkg -i tribler_7.0.2_all.deb
Selecting previously unselected package tribler.
(Reading database … 1987975 files and directories currently installed.)
Preparing to unpack tribler_7.0.2_all.deb …
Unpacking tribler (7.0.2) …
dpkg: dependency problems prevent configuration of tribler:
tribler depends on libsodium18 | libsodium13; however:
Package libsodium18 is not installed.
Package libsodium13 is not installed.
tribler depends on python-cryptography; however:
Package python-cryptography is not installed.
tribler depends on python-libtorrent (>= 0.16.18); however:
Package python-libtorrent is not installed.
tribler depends on python-pyqt5; however:
Package python-pyqt5 is not installed.
tribler depends on python-pyqt5.qtsvg; however:
Package python-pyqt5.qtsvg is not installed.

dpkg: error processing package tribler (–install):
dependency problems - leaving unconfigured
Processing triggers for gconf2 (3.2.6-0ubuntu2) …
Processing triggers for man-db (2.6.7.1-1ubuntu1) …
Processing triggers for desktop-file-utils (0.22-1ubuntu1.1) …
Processing triggers for gnome-menus (3.10.1-0ubuntu2) …
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index…
Processing triggers for mime-support (3.54ubuntu1.1) …
Errors were encountered while processing:
tribler

When I try to manually install the missing packages they can not be found:
sudo apt-get install libsodium18
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libsodium18 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libsodium18’ has no installation candidate

sudo apt-get install libsodium13
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libsodium13 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libsodium13’ has no installation candidate

So, what’s going on here ? Does tribler depend on packages from special repositories ?

Thanks,

Usjes.


#2

For Tribler, we use libsodium. It seems that required version of libsodium is not available in the repositories of Ubuntu 14.04 (which is a slightly old version anyway). As a workaround, you might be able to install the required libsodium package by following this guide. :+1:


#3

Okay so I have installed libsodium as per the instructions, but there are still other unmet dependencies:

sudo dpkg -i ./tribler_7.0.2_all.deb
Selecting previously unselected package tribler.
(Reading database … 1988043 files and directories currently installed.)
Preparing to unpack ./tribler_7.0.2_all.deb …
Unpacking tribler (7.0.2) …
dpkg: dependency problems prevent configuration of tribler:
tribler depends on python-cryptography; however:
Package python-cryptography is not installed.
tribler depends on python-libtorrent (>= 0.16.18); however:
Package python-libtorrent is not installed.
tribler depends on python-pyqt5; however:
Package python-pyqt5 is not installed.
tribler depends on python-pyqt5.qtsvg; however:
Package python-pyqt5.qtsvg is not installed.

dpkg: error processing package tribler (–install):
dependency problems - leaving unconfigured
Processing triggers for gconf2 (3.2.6-0ubuntu2) …
Processing triggers for man-db (2.6.7.1-1ubuntu1) …
Processing triggers for desktop-file-utils (0.22-1ubuntu1.1) …
Processing triggers for gnome-menus (3.10.1-0ubuntu2) …
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index…
Processing triggers for mime-support (3.54ubuntu1.1) …
Errors were encountered while processing:
tribler

sudo apt-get install python-cryptography
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package python-cryptography is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘python-cryptography’ has no installation candidate

Am I going to have to hunt down all these packages individually, is there something unusual about these packages, why wouldn’t they be available in the default Ubuntu repositories ?

Thanks,

Usjes.


#4

@Usjes We just released a new stable release Tribler 7.1.0 yesterday.
Could you try if this release works for you and let us know if you still have these installation issues?

Release forum post here


#5

I have tried installing 7.1.0 and, unsurprisingly, same result:

sudo dpkg -i tribler_7.1.0_all.deb
Selecting previously unselected package tribler.
(Reading database … 1988043 files and directories currently installed.)
Preparing to unpack tribler_7.1.0_all.deb …
Unpacking tribler (7.1.0) …
dpkg: dependency problems prevent configuration of tribler:
tribler depends on python-cryptography; however:
Package python-cryptography is not installed.
tribler depends on python-libnacl; however:
Package python-libnacl is not installed.
tribler depends on python-libtorrent (>= 0.16.18); however:
Package python-libtorrent is not installed.
tribler depends on python-networkx; however:
Package python-networkx is not installed.
tribler depends on python-pyqt5; however:
Package python-pyqt5 is not installed.
tribler depends on python-pyqt5.qtsvg; however:
Package python-pyqt5.qtsvg is not installed.

dpkg: error processing package tribler (–install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.22-1ubuntu1.1) …
Processing triggers for gnome-menus (3.10.1-0ubuntu2) …
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index…
Processing triggers for mime-support (3.54ubuntu1.1) …
Processing triggers for gconf2 (3.2.6-0ubuntu2) …
Processing triggers for man-db (2.6.7.1-1ubuntu1) …
Errors were encountered while processing:
tribler

So, what’s the conclusion here ? Is it not possible to run any recent version of Tribler on Ubuntu 14.04 LTS ?