Torrents always stop downloading shortly after starting the program

For the last few weeks, whenever I launch the program, the downloads do start downloading as expected (see pic)
image

However after a short while (could be five minutes, could be thirty), the download speed goes to zero and even if I leave the program running for hours, it won’t start again.
image

I have to close the program, and launch it again. Then the downloads will start, and the cycle repeats.

Am I the only one experimenting this? Is there a remedy I couldn’t find while browsing the forum?

I am using Triber 7.13.1, 1 hop of anonymity, no VPN, Windows 10.

2 Likes

Update - I tried downloading the torrents on another computer (same OS, software version, network), and I have the exact same issue. It takes a bit longer before not downloading anymore for some reason, but it ends up the same.

Update 2 - I downdated Tribbler to 7.12.1 and I don’t have the issue anymore.

1 Like

I’m seeing the same thing with Tribler 7.13.2. All torrents stall after a while. Also, CPU usage goes through the roof.

Rolling back to 7.12.1 for now because it still works fine.

1 Like

Same thing on 7.14 though it seems to happen after several hours for me. I’ve tried alternating the bandwidth settings to no avail. I’m using nordvpn as the proxy. CPU usage is 100% when this occurs.

My guess is that it is some sort of network queueing of hopped data. That restarting causes the hopped buffer to flush, whereas waiting causes larger but delayed buffers to flush on a more sporadic timeline.

Close Tribler
Open cmd

del %APPDATA%\.Tribler\trustchain.db /s
del %APPDATA%\.Tribler\*.pem /s

Start Tribler
It doesn’t fix the issue, but it will get your connections and downloading back again for a while.