[solved] Linux trying to git clone, ModuleNotFoundError: No module named 'ipv8'


#1

Hello,

on Arch Linux i had a directory with Tribler .tar.xz contents, now i wanted find a git command to update this directory with latest tribler version, yet mine command failed complaining:
“error: Your local changes to the following files would be overwritten by merge:”

but following command worked:
git remote add origin “https://github.com/Tribler/tribler.git” 2>/dev/null;git init;git checkout -f main;git clean -d -fx “”;git pull origin master||git pull origin main

(some unknown parts of it are unnecessary)

cd src;pip install -r requirements.txt
but when i tried to launch the src/tribler.sh:
ModuleNotFoundError: No module named ‘ipv8’

I see that the src/pyipv8 directory is empty on my end

maybe i had to use --recursive flag but i do not know how. Please any idea on the proper git command to sync from remote to local?
(on local i am not doing any modifications so force overwrite is ok)

If too difficult and disk space wasting, i would use tar…xz though i wanted to automate the update and .xz has a version in its name so can not easily do it.


#2

The command to get the git submodules is:

git submodule update --init --recursive

#3

that worked! Thank you for help, running Tribler now