Snapcraft for Tribler


#1

I have made a snap for Tribler version 7.7.1 that runs great on, at least, OpenSuse Tumbleweed and Ubuntu 18.04

If you have snapcraft installed you can try it by typing:

snap install --edge test-tribler

A few seconds later, you should have tribler installed on your system and you can run it from your start menu.

In the past I have tried running tribler directly on OpenSuse, which was insanely difficult because it required recompiling python against an alternate compiled openssl that had elliptic curves enabled.

Then I made a docker image that connected with X11, and used that for a while. Problem there was that after a while the tribler gui would not show on my system anymore (don’t know why).

Then I made a docker image that I could connect to with VLC. This worked fine, but was quite the resource hog.

For some time the 32 bit tribler windows version ran fine on wine on my OpenSuse box. But the newer versions have issues.

This snap runs great and super stable on my OpenSuse tumbleweed, and on kubuntu 18.04 in a virtual machine. I hope it will run well on other systems as well. Perhaps this can motivate some people on the development team to release future versions of tribler on snapcraft as well.


#2

This kind of activity is very welcome on our GitHub page. Would you kindly create an issue or start a discussion there?


#3

Thank you, I copied this message over to a new message on your github page.


#4

I made a snap for version 7.8.0 as well now. If you have been using the snap for 7.7.0, and want to upgrade, do the following from your bash prompt:

sudo snap install --edge test-tribler780
test-tribler780

Now the newer version should run. Just exit the program again, and do the following (this copies the settings of your previous tribler snap to the new one):
cd ~/snap/test-tribler780/current
cp -r ~/snap/test-tribler/current/. .

Now you can re-run the new version and check if all settings from the previous version work in the new version. If you are happy with the result, you can remove the previous version:
sudo snap remove test-tribler