No peers connecting


#1

I’m using Tribler 7.5.0-rc5 (and also tried 7.4.4) and it seems to have some issues with connecting with other peers.

I have torrents seeding that I know have others wanting, but my client keeps saying 0 seeds 0 peers. I can download all right, without issues, but when it comes to seeding it seems to find and then drop clients that aren’t Tribler.

Is this a known issue?

Can I open a specific port to enable easier access? I found that I should open 7759-7760, but that doesn’t seem to do anything specific. I can’t see that it uses any of those ports for TCP communications.


No peer without anonymity
#2

UPDATE

I found out how Tribler randomizes the ports, so I found which ones it used instead of the ones mentioned in my previous post. However, the problem still persists.

For example, if I set the anonymous hops for a torrent to 0, then it will seed almost instantly, even though a little wonky in the connections to. If I then set it to 2 hops for anonymous again it stops.

Is this related to the fact that I have a negative balance in token balance, that I’m not allowed to seed over the network to outside clients?


#3

Are you behind a cgnat environment?


#4

No, I’m not, I have a public IP.

Other services I use works fine, but Tribler seems to be stuck. No connections at all for ~24 hours once files are done and set to seeding.


#5

I live within NL and use Ziggo as a provider. I have Ipv6 and Ipv4 through Ziggo’s NAT, so I have the same problem as you and I wait desperately for Tribler to support Ipv6! Just so I can support others. Now I am only taken.


#6

I notice the same lately. Anonymous downloads have nearly halted. Furthermore, the number of visible seeds and peers is far lower in anonymous mode than when I revert to non-anonymous mode.


#7

Using anonymous mode, be it 1 or 2, results in zero seeds and peers. Changing to non anonymous mode ‘solves’ the problem. So something is wrong with one of Triblers essentials. I’m using 7.5.0-rc5. Port 8085 (default). Most recent other updates (if of any importance): Windows 10 Pro (build 18363.815) and VLC (3.0.10).


#8

I’m suffering from the same problem currently. Both 7.4.4 and 7.5.0-rc5 will not connect to any peers while any anonymous hops are active. Resetting the .tribler folder allowed one torrent to achieve a momentary couple b/s connection, then promptly went back to 0 peers.


#9

Here’s an example of a session that has stalled after running for several hours.

As you can see there are several discovered peers and seeds, but it usually just goes through batches of 20-50, or something like that, and then nothing stays and it goes back to 0 peers/seeds connected again.

A few, rare, times the torrent keeps a peer for a few minutes up to perhaps 5 minutes maximum, goes up in speed and gets a few blocks of the file. Speed is no problem when this happens as I’ve seen up to a few hundred kb/s up to 1MB/s. But then it falls away and never connects again, regardless of how many hours I keep the application open for.


#10

I’ve been suffering the same thing for the last few days on both windows 10 and Debian 10. No downloading for hours then maybe 5 -10 minutes of downloading then back to nothing. Works fine without anonymity.


#11

Same here. With de 7.5 rc’s and, after replacing it, with the 7.4 stable one. The stable version at first provided contact with peers and seeders but only for some minutes. Anyone any clue? By the way: at the moment I even can’t adjust new downloads. It seems some old problems are troubling Tribler again.
Edit: adjusting new downloads is possible (just had to wait little bit longer) but the zero seeds/peers issue hasn’t been solved.


#12

i’m also seeing this issue. v. 7.4.4


#13

Tribler 7.5.0-rc5 on windows 10. Uptime today 7 hours total MBytes given to community zero. Tried a torrent on qbittorent download fine ,Tribler doesn’t even download the metadata. Can somebody explain whats wrong.


#14

All anonymous downloads have stalled. Furthermore, downloading metadata, both from recently updated Tribler channels, as well as downloading it from outside the Tribler network fails. It results in a timeout.

@devos50 @ichorid @sandip Are you aware of this problem?


#15

Thanks for reporting!
Currently, since yesterday we experience a technical problem with our exit nodes. These should be resolved in 1-2 days. Please, report if the problem persists after that.

Note that the problem with the exit nodes should only affect anonymous downloads. When you uncheck the “download anonymously” checkbox, the metainfo request will be immediately retried directly.


#16

The problems described here already manifested themselves at least 2 weeks prior to yesterday though.


#17

I can confirm LesVerres’s finding: the problem is not here since yesterday. On the other hand I can conform ichorid’s words about the workaround. Gives you seeds and peers back again. Yesterday I completely deleted every trace of Tribler, even in the registry, and after that I installed the latest stable version (7.4.4). The problem seemed to be solved by that but that only lasted for a short time.


#18

@LesVerres, please try unchecking the “download anonymously” checkbox, or even disable it by default in the options. Getting metadata through tunnels is unreliable.


#19

I would have expected it to work when downloading non-anonymously. Doing so would however defeat the purpose of Tribler.

Thanks for looking into it, I wasn’t sure of you were checking the forum regularly.


#20

@LesVerres , 7.5 development have been effectively frozen during the last few weeks as the lab was busy doing other things.
Also, if you have idea how to deal with anonymous vs non-anonymous DHT checks by default, please share your thoughts.