GUI Handler Error

Hi there, I’ve been getting a bug report at shutdown for a week or so, along with the odd problem of the downloads menu showing nothing but loading, despite network activity and completed downloads with time. This issue appears similar to Error on installation, and possible gui bug with some minor variations.

Below is the summary log, I have a much longer one if you want to look back farther

[01/Jan/2017:23:11:40] ENGINE Serving on 0.0.0.0:8080
INFO 1483337500.23 cplogging:201 [01/Jan/2017:23:11:40] ENGINE Serving on 0.0.0.0:8080
ERROR 1483337502.30 GuiDBHandler:253 'Traceback (most recent call last):\n File “Tribler\Main\Utility\GuiDBHandler.pyo”, line 121, in wrapper\n File “Tribler\Main\vwxGUI\SearchGridManager.pyo”, line 832, in getHitsInCategory\n File “Tribler\Main\vwxGUI\SearchGridManager.pyo”, line 826, in create_torrent\nTypeError: can only concatenate tuple (not “list”) to tuple\n’
Traceback (most recent call last):
File “wx_core.pyo”, line 14669, in
File "Tribler\Main\vwxGUI_init
.pyo", line 128, in invoke_func

File “Tribler\Main\vwxGUI\list.pyo”, line 290, in _on_data
File “Tribler\Main\Utility\GuiDBHandler.pyo”, line 254, in get
TypeError: can only concatenate tuple (not “list”) to tuple

Thank you for your report. We are dropping support for the wx GUI and we are currently in the process of creating a new, more stable GUI as part of our Tribler 7 release. Tribler 7 is currently being tested internally and we hope to create a public alpha release soon.

Hope this helps!

Tribler 7.12.0-RC3 did not start! Test it on 2 Win11 Systems

tribler bug