Giga Channel release (Beta1) is out. Yay!

Dear Tribler Community,

We’re now one small step closer to becoming Youtube-like. Each Tribler user can now publish a million magnet links and download a whole channel in a minute. This was made possible by Giga Channels. Upgrade or create a new channel now with this release.

Another important update on this release is the Tribler tokens. We have fixed (partially) the negative balance issue so now you should be able to easily earn tokens by being a relay and supporting anonymous downloads. Apart from this, we have revamped the GUI and included several performance and bug fixes. We hope you’ll find it faster and better. However, this is a beta release and there are rough edges but we would like to ask you to upgrade and try out this version.

The binaries are available below or can be downloaded from the official release page at Github repository.
Windows (32-bit)

If you encounter any problems using this release, feel free to report back to us. We’ll appreciate that. You can either create an issue ticket in Github (link here) or simply post it here in this forum.

For developers willing to contribute to Tribler with bug fixes or new features please check out this page which provides the basic pointers to get started.

And as always, the source code can be found on our Github repository but you can also download it directly here.

We hope you’d enjoy using this version.

I receive the following error when I try to start:

Traceback (most recent call last):
      File "TriblerGUI\", line 118, in on_received_state
    RuntimeError: Unhandled Error
    Traceback (most recent call last):
      File "lib\site-packages\twisted\internet\", line 428, in fireEvent
      File "lib\site-packages\twisted\internet\", line 321, in addCallback
      File "lib\site-packages\twisted\internet\", line 310, in addCallbacks
      File "lib\site-packages\twisted\internet\", line 653, in _runCallbacks
    --- <exception caught here> ---
      File "lib\site-packages\twisted\internet\", line 441, in _continueFiring
      File "", line 85, in start_tribler
      File "Tribler\Core\", line 411, in start
      File "Tribler\Core\APIImplementation\", line 153, in register
      File "Tribler\Core\APIImplementation\", line 287, in init
      File "Tribler\Core\Modules\MetadataStore\", line 132, in __init__
      File "lib\site-packages\pony\orm\", line 1130, in generate_mapping
      File "<auto generated wrapper of check_tables() function>", line 2, in check_tables
      File "lib\site-packages\pony\orm\", line 528, in new_func
      File "lib\site-packages\pony\orm\", line 1203, in check_tables
      File "lib\site-packages\pony\orm\", line 78, in check_tables
      File "<auto generated wrapper of execute() function>", line 2, in execute
      File "lib\site-packages\pony\orm\", line 61, in wrap_dbapi_exceptions
pony.orm.dbapiprovider.OperationalError: no such table: ChannelNode

This happened while using the Windows 64bit version.

Nice work, thanks. Unfortunately it refuses to start on ubuntu 18.04…

Please, see attachment.


I had the same problem. I fixed it by installing the 7.3.0-alpha first, letting it run for the hour or more it took to update everything, and then installing the 7.3.0-beta.

@LesVerres It is a conflict with existing version because of a database format change since last experimental version for 7.3. To resolve this, you can remove metadata.db present in sqlite directory of your state directory but you’ll loose your experimental version channel if you have.

Do you still have the issue? Tribler takes some time to upgrade the database so this could be what you’re experiencing. Let us know if Tribler still does not work for you.

That worked, although some torrents that I was sharing have mysteriously disappeared from my download list.

Edit 1 04-04-2019:

Another thing I noticed, downloading via magnet links doesn’t seem to work anymore. It keeps waiting for metadata.

Edit 2 04-04-2019:

One of them finally started to download, but this behavior I haven’t encountered in earlier versions of Tribler 7.

It does not find any of the channels that were available in the older versions of Tribler. Is that intended behaviour?

Is it correct that token mining isn’t working yet? I did enable it in the settings, chose a channel to mine from and had Tribler running for hours.

I’ve encountered the following error:

Traceback (most recent call last):
    File "TriblerGUI\", line 136, in on_read_data
RuntimeError: [Failure instance: Traceback: <type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'address'
--- <exception caught here> ---

I’m using Windows 10 64-bit.