Failed to execute script pyi_rth_qt5


#1

Hi there!

Just installed Trible (v7.0.1, windows 8.1) for the first time this morning and could not start using it since it just won’t start and keeps giving me this message:
failed to execute script pyi_rth_qt5

Tried running it as administrator (fail), tried reinstalling Python 3.6.4 (fail).

What can I do?

Thanks for your help


#2

No one?

Is it a known issue?
(I’d made some search on the forum and only found one mention of the error “failed to execute script pyi_rth_qt5” but I didn’t see any solution…)


#3

@goulamas Thank you for your report. Current Tribler version v7.0.1 uses Python2.7 so might be somehow conflicting(less likely) with existing Python 3.6.4. We’ll investigate the issue.


#4

Similar ¿bug? in my case.
I’ve just installed Tribler 7.0.2 x64 on Windows 10, and I’m unable to make it work. The only thing I see is a message telling Failed to execute script phy_rth_twisted.

Any idea?


#5

@maherran Could you please share the logs so we have more ideas on what’s wrong?
Also we would like if you could try out the latest experimental release and tell us if problem still exists.
You can download the installer from following Github page.


#6

This is from experimental release:


In fact, I don’t have c:\python27…

As an additional information, I’ve installed Microsoft Visual Studio with Phyton 3.6. I hope it helps…


#7

@maherran Thank you for the report. For some reason, I’m not able to reproduce the issue on quick test. I tested on Win10 x64 bit machine having Visual Studio Code with Python3.6 extension installed but Tribler seems to run fine there.

Tribler runs on Python2.7 but it is not necessary to install it separately. It comes bundled with Tribler. The issue you have could be because of the conflict with system Python3.6. We’ll further investigate and let you know.

Could you …

  • try uninstalling Python3.6 and installing Python2.7 and check if Tribler works?
  • share your install location? Does it have any unicode characters in it?

#8

Installed Python2.7. Exactly the same error.
Install location: C:\Program Files\Tribler (the one taken by default)

Honestly, I don’t know what to do…


#9

I’m getting crazy.
Just to try something different, after installing Python2.7, I reinstalled Tribler 7.0.2.
And again, I’m on the initial message: Failed to execute script pyi_rth_twisted.
I’ve searched pyi_rth_twisted.py on the Tribler installation, but I didn’t found it, neither on the Python2.7 installation. Should it be there?