Entry Point Not Found


#1

tribler

Just tried installing twice. Tried to just open it and got the message on the screen. It is persistent too. If you click the OK or X out it pops right back up. Nothing will close it out short of turning off the pc. Not even the Task Panel will kill it. Also tried trying a magnet link and it does the same.

I installed it first and it chose to install directly into the Program files. 2nd time I tried in Programs (x86) because that is where my VLC player in located.

Suggestions?


#2

Thank you for your report. Which version of Tribler did you install and is this the 64-bit or 32-bit version?

We fixed a few bugs in the latest experimental release which you can download here. Please note that this is an experimental release and not backwards compatible with Tribler 7.0 without affecting existing downloads.


#3

I took the only one available for Windows. 7.0.2 version is the only option on the main website page and also on the DL page for Windows system. You don’t get a choice between 32 or 64 versions.

My system is Win7 64 bit

As for beta versions of anything, I always avoid unless I have no choice.


#4

Hmm you’re right; we should publish the 32-bit version on the website.

Regarding your VLC issue, the integration between VLC and Tribler works as follows (at least for 7.0.2): Tribler searches for a VLC version installed on the system. It is likely that you have VLC 3.0.2 installed, which is not compatible with Tribler 7.0.2. This is a tricky situation and we fixed this by bundling VLC with Tribler itself (instead of relying on a system-wide installation of VLC).

For now, I see three possible workarounds:

  • downgrade your VLC version to 2.2.4
  • download the experimental release of Tribler 7.1
  • you could remove your system-wide VLC if you do not use it

We apologise for the inconvenience and this will be fixed when we release Tribler 7.1!


#5

VLC is my only media player. I’ve disabled Win Media Player way back during the XP days and never looked back. It’s been at least 3 computers in a row where all I use is VLC.

I need VLC to play my videos, gifs, etc.

So I need it system wide. So what are my choices now?


#6

This is now working for me in the 7.1.0 Exp 3 release which I have installed today.
I understand that you do not want to install experimental releases but for others this might solve this issue.


#7

So the beta is working with the latest version of VLC system wide?

Also, I have a bit of time. If they hope to have the beta done in weeks instead of months I could wait out July.