Entry Point Not Found - Windows 7


#1

I cannot open this. I think the issue is to do with VLC. I tried the 7.1 exp3 version but when I open that a CMD window opens for a second and then closes. I am using windows 7 64bit.


#2

We fixed various bugs after 7.1.0-exp3. Please try out the very latest build. You can download it from our infrastructure here: https://jenkins-ci.tribler.org/job/Build_Tribler_next/

Please let me know whether this resolves the issue for you :slight_smile:


#3

Still doesnt work.

I also tried version 6 but that refuses to do anything when I open it. :frowning:


#4

Could you copy and paste the whole stack trace that is visible in the right screenshot? We have very limited information now to debug this.


#5

Traceback (most recent call last):
File “TriblerGUI\core_manager.py”, line 114, in on_received_state
RuntimeError: Unhandled Error
Traceback (most recent call last):
File “lib\site-packages\twisted\internet\base.py”, line 417, in fireEvent

File “lib\site-packages\twisted\internet\defer.py”, line 317, in addCallback

File “lib\site-packages\twisted\internet\defer.py”, line 306, in addCallbacks

File “lib\site-packages\twisted\internet\defer.py”, line 649, in _runCallbacks

— —
File “lib\site-packages\twisted\internet\base.py”, line 430, in _continueFiring

File “run_tribler.py”, line 73, in start_tribler

File “Tribler\pyipv8\ipv8\util.py”, line 14, in helper

File “Tribler\pyipv8\ipv8\util.py”, line 26, in blockingCallFromThread

File “Tribler\Core\Session.py”, line 483, in start

File “Tribler\Core\APIImplementation\LaunchManyCore.py”, line 187, in register

File “Tribler\Core\Config\tribler_config.py”, line 307, in get_ipv8_bootstrap_override

exceptions.ValueError: need more than 1 value to unpack


#6

Thank you for your quick response. This is an error that was introduced (and fixed) during experimental builds. To fix this, please open the Tribler configuration file and edit it. On windows, you can find it under %APPDATA%\.Tribler\triblerd.conf. Remove the line that starts with bootstrap_override. Tribler should then start again. :+1:

Also, we are about to release Tribler 7.1 beta (today) so if you want to try that version, please download it from https://jenkins-ci.tribler.org/job/Build_Tribler_next/40/ :slight_smile:


#7

I am using 7.1 beta, I removed that line in triblerd.conf and I still get the error.
I got it from here: https://jenkins-ci.tribler.org/job/Build-Tribler_Win32_next/
Traceback (most recent call last):
File “TriblerGUI\core_manager.py”, line 114, in on_received_state
RuntimeError: Unhandled Error
Traceback (most recent call last):
File “lib\site-packages\twisted\internet\base.py”, line 417, in fireEvent

File “lib\site-packages\twisted\internet\defer.py”, line 317, in addCallback

File “lib\site-packages\twisted\internet\defer.py”, line 306, in addCallbacks

File “lib\site-packages\twisted\internet\defer.py”, line 649, in _runCallbacks

— —
File “lib\site-packages\twisted\internet\base.py”, line 430, in _continueFiring

File “run_tribler.py”, line 73, in start_tribler

File “Tribler\pyipv8\ipv8\util.py”, line 14, in helper

File “Tribler\pyipv8\ipv8\util.py”, line 26, in blockingCallFromThread

File “Tribler\Core\Session.py”, line 483, in start

File “Tribler\Core\APIImplementation\LaunchManyCore.py”, line 226, in register

File “Tribler\Core\APIImplementation\LaunchManyCore.py”, line 367, in init

File “Tribler\dispersy\util.py”, line 46, in helper

File “Tribler\dispersy\util.py”, line 225, in blockingCallFromThread

File “Tribler\dispersy\dispersy.py”, line 1621, in start

File “Tribler\dispersy\database.py”, line 113, in open

File “Tribler\dispersy\database.py”, line 141, in _initial_statements

sqlite3.DatabaseError: file is encrypted or is not a database


#8

It seems that your Tribler database got corrupted somehow. You can safely remove the Tribler database since you will rediscover the content that Tribler discovered anyway. Please backup and remove the sqlite directory from the Tribler state directory (in %APPDATA%\.Tribler). Next, start Tribler again and it should get past this error.


#9

That worked, is there a way to hide the CMD window though?


#10

Good that it works and thank you for that remark! We forgot to disable it before building :confused: . We will disable the console and make another build!