Downloads are not kepping alive


#1

On an old Linux notebook I use Tribler without a VPN. If downloads have a lot of seeds, they will run.

It is noticeable that the downloads collapse or, crawl forward very slowly or stop. When I restart Tribler they come back to life.

Why give Tribler the downloads not an kick under the ass, Just like other bittorrent programs.


#2

I’ve had the same problems since after 6.52. New systems, old systems different OS. e.t.c. I tried different permissions with no luck. As soon as anything other than tribler runs even a screen saver tribler stops all activity and you can’t recover with an Ano change or forced recheck. You have to exit, clear the roaming folder and start all over again. Sometimes i’l be seeding the same 1% download for days on end i still go negative. Seems seeding is futile when no one is getting any more than that 1% that i was able to initially get.
Just running TB and typing in this message locked up tribler, downloads and seeding are completely stopped and are not recovering. And yes tribler does stop on it’s own for no reason and at times i get a bunch of FW alerts from a tribler server when tribler gets stuck in theses endless loops. There are no warnings that come up either and ctrl-alt-del task manager (linux eqv as well) is needed to shut down tribler.
Yes i did try without a FW , no difference.
Also if you don’t set checking to false, tribler locks up even quicker after a fresh install.
Also tried with or without VPN. With Linux distros that had a-lot of seeders.
Running out of options to try.


#3

Well, that’s really sad to hear that Tribler does not work for you :frowning_face:
Under the hood, Tribler uses LibTorrent library. You can try using another LibTorrent-based client, such as Deluge, and report back if it solves your problems. If it does, that’s good news for us, since we can probably fix it. If it does not, the problem is probably in LibTorrent itself.

Recently, it was discovered that LibTorrent has a bad problem with UDP-based connections with other clients. Deluge is affected too.

Also, there are two Tribler-specific issues:

  1. The first is about sharing magnet links for rare torrents.It was solved recently. The first release with the fix is 7.10
  2. The second one is much more tricky. When you seed anonymously, the torrent you seed is only available through an anonymous tunnel, which adds a lot of latency, which affects the upload speed negatively. This means that external downloaders will prefer other seeds, if available. Non-anonymous seeds are much faster. So, when you seed something anonymously, don’t expect to see good upload rates, unless you’re the only seeder out there. And then - see problem #1 above :man_shrugging:

In short: try Deluge, download the latest 7.10 experimental release, don’t use anonymous seeding unless absolutely necessary.


#5

Still the same problems with Deluge but less often.
I had to remove the latest 7.10 (7.ten) of tribler and go back to 7.4.0 exp4 . It’s the only build that works except for CTD’s from using the search bar.
I can tell you that watching the tribler diagnostic panel during loading or use i can see an inordinate number of "unable to locate in table bootstrap errors including for dht and this is when the FW picks up the retries from the tribler server.


#6

What do you mean by “7.4 is the only build that works” exactly? You mean, seeding anonymously?

Also, the DHT messages are probably from Tribler DHT, which is different from Mainline DHT used by BitTorrent protocol. Tribler DHT was fixed many times since 7.4. It is used for our hidden seeding (Tribler<->Tribler anonymous) feature.

Also, it is intriguing that you say only 7.4exp4 works. Could you try other versions around that one?


#7

Also, could you please make a screenshot of your Debug panel in the version that works for you the best, and post the logs file from any non-working version here? That would help us greatly.


#8

Still working on it. What does repeat itself is tribler being blocked from writing to disk. It’s less of a problem in Linux but in windows i will often have to restart tribler and do a forced recheck and then the speed for seeding and downloads resumes. If i install explorer++ in place of base windows explorer the problems almost vanish.
As to what triggers the tribler block i don’t know there is nothing in the trace.

Uh oh. spoke too soon. Tribler is now frozen in the download with the kb/s rates also frozen at what ever they were at the time. I can not stop the downloads/seeding.
I can not shut down tribler normally and have to use task manager and now tribler being stuck in a loop has lass.exe stuck trying to contact a server. Will have to reboot the net and come back later.


#9

It sounds like your hard drive / SSD is failing…


#10

Storage checks out and is stable. Remember, it works fine on the same system booted into linux.
I also previously said i changed it’s install and storage to different drives in windows.

Right now i have it working in Linux with the same vpn so that’s all the time i’l be spending on the windows version. There are just too many network hook requests with the MS windows version. Deluge as you suggested works as does utorrent including port forwarding.
Even in no-anonimity (ms windows) tribler will often not connect.

You can close this thread if you wish and Thank you for trying.


#11

So, to sum it up, in Linux everything is fine, while in Windows Deluge and uTorrent work, while Tribler freezes regularly, right?


#12

Also, could you try running Tribler on a virtualized Windows machine, say, VirtualBox? That will abstract out the potential drivers problem and leave us with a clear system. Also, in case there are still problems in the VM we could arrange a TeamViewer session without compromising your security.

Your case worries me a lot. If Deluge works, but Tribler is not, there is clearly something wrong going on.