Debian Linux - Tribler Version 7.5.2 does not start after installation


#1

I installed today Tribler by runnung:

wget https://github.com/Tribler/tribler/releases/download/v7.5.2/tribler_7.5.2_all.deb
sudo apt-get install ./tribler_7.5.2_all.deb

Then i had in my Gnome gui the tribler logo and i tried to start tribler but nothing happens when i click on it.
I tried then running tribler from the command line. I can read this:

tribler
Starting Tribler…
/usr/share/tribler ~

And then the process seems to stop again.

It does not seem to be related to Tribler doesn't start on Arch Linux! because i do not have any ~/.Tribler/ directory.

I dont know how to go on from here with this issue. I checked if there is some verbose debugging output, but running “tribler --help” does not show any options.


#2

Thanks for reporting!
What exact version of Debian do you use? Did you use Tribler before on the same system?


#3
Distributor ID: Debian
Description: Debian GNU/Linux 10 (buster)
Release: 10
Codename: buster

I have never used Tribler on this system before.


#4

I spend some more time understanding this tribler project and find out that the installation tool is just a bunch of binaries like vlc and so on packed into a file. This dont make that much sense for me and i simply run it just like a normal software using the normal tools of my system and it seems to work fine. Howto: https://github.com/Tribler/tribler/blob/devel/doc/development/development_on_linux.rst

This bug is still not fixed but i question now the need of packaging this huge amount of software into a deb file.

Please add tribler just to the official repo so that its listed here: https://packages.debian.org/search?keywords=tribler&searchon=names&suite=all&section=all


#5

We’re going to pay closer attention to packaging and platform support this fall. Tribler is in constant development flux, so packing it in the official repository of Debian will hamper our ability to provide frequent updates. We were thinking about creating our own PPA though.


#6

A PPA would be nice. For arch linux users you can create frequent updates via AUR. Maybe there are some Arch linux users here who would like to see it here https://aur.archlinux.org/packages/?O=0&K=tribler


#7

This is not a technical problem, but a problem of lack of resources. We’re severely understaffed for our ambition level. Most of our developers use Linux or MacOS, but 90% of our users are Windows users. We just can’t afford to spread our effort further than it is now.


#8

Same to me @ichorid.

Debian 10.5 up to date.
From 7.5.0 to 7.5.2, tribler never start and say nothing.
Remove tribler, installing vlc, installing tribler 7.5.2, tribler never start and say nothing.
Remove tribler, installing 7.5.1, tribler start as usual.


#9

To fix a crash on Windows, we had to upgrade our Python interpreter to 3.8 for Tribler 7.5.2. Consequently we had to recompile and update Libtorrent and VLC libraries. Typically we don’t do such drastic changes in minor releases, but the crash was bad so we had to act. Ironically, the upgrade introduced more problems that it had solved. We apologize to those users who were affected by these.

In the meantime, for Debian users: the problem with 7.5.2 is with Pyinstaller-packed modules and interpreter versions with your system. Please try to install from source. You will have to install the necessary dependencies by hand, though.


#10

@owned
I can recommend to use this. You then dont mixup different software versions of different software that is build into the tribler-binary that is on the website.


#11

I’ve gottern the exact same behavior from the newest version. Very frustrating, particularly since I can’t run a Tor relay on this machine.

Kubuntu 18.04
Kernel 5.4.0-47-generic


#12

@Kencf0618

I cant recommend to use this binary from the website. Just download the original program from github. Its working MUCH better that way and you also dont run into security issues because of prebuild and outdated packages that are inside the tribler prepacked-package.

Here is what i recommend to run tribler that fixed my issue: https://github.com/Tribler/tribler/blob/devel/doc/development/development_on_linux.rst