7.5.0-exp1 is released!


#1

Dear Tribler Community,

The first experimental release of Tribler 7.5 series is ready for daring testers on GitHub! It features two major changes:

  • Nested Channels. Users can now create more than one personal channel. Channels now can feature an arbitrary sub-structure of folders, just like in a real filesystem. Also, the Channels GUI was refactored for speed.
  • AsyncIO reactor. Tribler now uses modern AsyncIO reactor instead of the old Twisted framework. This should help with performance and stability.

Overall, Tribler Core was heavily refactored for this release. Also, security-wise all DHT checks now go through Tunnels by default. As usual, it is advised to backup your Tribler state directory before checking it out.

The binaries are available below or can be downloaded from the official release page at Github repository.
Windows(64-bit)
Windows (32-bit)
Linux (generic)
Linux (Ubuntu 18.04)
MacOS

Hope you enjoy the new Nested Channels feature!
Cheers!


#2

ubuntu 5.3.0-40-generic

hmmm /home/tribler/ hmmm

Traceback (most recent call last):
File “/home/tribler/jenkins/workspace/Build-Tribler_release/Async-Py3-Build-Ubuntu64/tribler/src/tribler-gui/tribler_gui/event_request_manager.py”, line 114, in on_read_data
RuntimeError: [Errno -2] Name or service not known


#3

Exact Ubuntu version? Works fine on our 18.04 tester machines.
Also, it would be nice if you post your Tribler log here.


#4

Ubuntu 19.10 5.3.0-40-generic

dont have the log no more, will attach if it happens again, for now it works, the error happened when starting the aplication.

edit:
cisf-tribler-7CjRIObc.log (98.9 KB)


#5

Thanks, the log helped a lot!


#6

Have had the same crash as cisf running Debian 10.3 but tribler does not seem to be saving any log files.
Also cannot select the files in a torrent, error message ‘LibtorrentDownloadImpl’ object has no attribute ‘set_selected_file_indexes’.
This version does seem to close the ports it opened when it is shut down , unlike every other version I have tried.


#7

Confirmed. Thanks for reporting, adding to GitHub.


#8

Both seeds and peers remain at zero for all downloads after installing this update.


#9

Thanks for the report!
I suspect that this is only true for anonymous downloads. Could you please try downloading some nicely seeded torrent (like Ubuntu 19.10) and see if it works for you w/o anonymity and with two and three hops anonymity modes?


#10

Indeed, the mentioned behaviour only occurs with anonymous downloads with one to three hops.