7.4.3: new user: Torrent made and shared with Tribler isn't uploading


#1

I created a torrent with Tribler and quickly had 5 to 6 peers for it. At the moment, I seem to have 9 peers (for a few days) but NOBODY has been able to upload 1 byte up to now… They can’t even see the contents of the torrent. Why? Are there any trackers I can add / edit? I opened 2 more torrent clients and have them trying to download from my Tribler Seed but… They fail too. No privacy hops have been set. Adding the torrent to My Channel did not seem to change anything either.

Help! :slight_smile:

Post edit: I created a triblerbootstrap.txt

# file: bootstraptribler.txt
# default bootstrap peers
server1.always-online.org 6420
host1.never-offline.russia 6420
sealand.routed.org 6420
168.0.0.13 6420
# default TUDelft bootstraptribler peer
dispersy2.tribler.org 6422
dispersy3.tribler.org 6423
dispersy4.tribler.org 6424
dispersy5.tribler.org 6425
dispersy6.tribler.org 6426
#trackers from utorrent
udp://open.stealth.si:80/announce
udp://retracker.lanta-net.ru:2710/announce
udp://tracker.internetwarriors.net:1337/announce
http://share.camoe.cn:8080/announce

… and many more trackers I ripped from here and there (confirmed working with utorrent 2.2.1)

As far as I understand, the Default entries should be hard-coded in Tribler itself. And the trackers’ syntax I added won’t work?
That said, I do have 20 peers 1 hour later. Some of them connect for a few seconds before disappearing again… Why? :frowning:


#2

It could be that you are behind a very prohibitive firewall or NAT and thus not connectable from outside. Try seeding in hidden mode instead. That circumvents the NAT problem.


#3

Thanks, but there is no NAT. That said, I will look for that hidden mode.

And a PS: qbittorent has uploaded 25GB in the last few days… Also pointing to another problem then NAT?

Till repost! : )

Update: Hmmm… Hidden Mode…?? Where’s that? :slight_smile:


#4

Oh, did you mean I should use some anonymity, say 1 hop? I started out that way but gave that up because it wasn’t uploading back then either. I’ll try again, but… :confused:


#5

BTW, dispersy trackers got nothing to do with BitTorrent. These are trackers for IPv8, our P2P messaging library.


#6

Also, by chance, do you happen to have IPv6 address in addition to IPv4 one? Another thing you could try is using someother Libtorrent-based client with the same torrent file and see if it works.


#7

Ok, no surprise there. And it confirms my suspicion: Tribler does not use trackers, other than internal ones OR IPv8 ones! Got it : )


#8

I seem to have IP6 addresses, including DNS… And now? : )


#9

I’d like to keep the URI I already have (made by Tribler). Re-creating the torrent is not my first option if I can avoid it :slight_smile:

I can have my other 2 torrent clients “repair” the torrent once they downloaded 1 byte from Tribler. As I mentioned before, both clients are unable to download this Tribler-created torrent. They can’t even get the file contents : (

Post-edit: https://ipv6-test.com/ denies I have a functioning IP6 connection
Post-edit: 7.4.4 was released - I’ll upgrade next.


#10

You can export the torrent file for any torrent that is seeded in Tribler by clicking the right mouse button on it in the Downloads list and selecting “Export torrent file”. Then you can try seeding it with another client.


#11

Looks like it’s a local problem after all…

I switched to fiber 2 months ago and I just plugged my own wifi router to it and all seemed well. I had some torrents that uploaded and due to personal reasons, I hadn’t done anything with the rest of my network. I thought all was good.

So to verify I connected directly to my ISP modem and the downloading has started…

Ah well, at least I learned something about Trible. Thank you, sorry for wasting your time. Next for me is putting my Wifi router in the right modus (I was surprised that it worked to begin with!) xD

Peace!

Devvie


#12

Maybe I spoke too soon. While I’m now directly connected to my ISP router and utorrent indeed downloaded 800kB from my Tribler seed (crashing Tribler due to full disk), downloading seems halted again. No peers that connect and stay connected either. I’ll let it run overnight. And take a fresh look when it’s day : )

Good night :confused:

Update: utorrent 2.2.1 says my internet connection is OK (green mark)
UPDATE: I removed all trackers and I’m back to 1 peer instead of many… Looks like Tribler secretly does support trackers when you add them in triblerbootstrap.txt???!


#13

This is slowly developing into a real problem : (

When I disconnect my wifi, uploading to urtorrent works instantly. (I don’t use a network cable on this PC…). Which explains why I had limited success yesterday with uploading.

I created another torrent with utorrent and set it to seeding. A lot of time has passed, but it too wasn’t uploading even 1 byte, despite it having 30 peers.

Again, at times, utorrent gives the green check-mark that my connection is all good.

And again, some of my other torrents (Windows ISOs) have a ratio of over 50x upload traffic (in a few months). So SOME upload traffic happens. But in retro-spect I have to admit, they could have uploaded a LOT more… Many peers, only a few seeds… That shit should be lit! :slight_smile:

Something is really really wrong on my (ISPs) end. What? I don’t know. There are no (online) tools to test throttling. I’m in Europe, NL so that shouldn’t happen.


#14

As a test, I am downloading the official torrent for ubuntu-19.10-desktop-amd64.iso. I have it downloading both in Tribler and in uTorrent 2.2.1.

2 things stand out;

  • it seems both downloads maximize at around 1 MB/s. Its max is 20 MB/s. Quite a difference!
  • both aren’t uploading anything. +3000 seeds and +1300 leechers. Up-speed close to or equal to 0 kB/s.

I’ll give this a few hours (see what gets uploaded) before I’ll get a VPN that supports torrents. Let’s see if PPTP changes anything :confused:


#15

Update: the Ubuntu torrents both have downloaded.

In Tribler, many connected peers but none of them download anything from me.
In uTorrent,I keep seeing peers connect and disconnect. Nobody stays connected or downloads anything.

So… VPN is next. Which will fail too (I already tried yesterday). Then, I’ll go to a friend with another provider and see what happens there. If THAT fails… It must be a Windows 10 problem (I sure hope not!).

Is UPnP still a thing for torrents? :slight_smile:


#16

I don’t know about UPnP, but you can try seeding/downloading in Tribler hidden mode. This is roughly equivalent to using VPN, because your provider can’t see what kind of traffic is going through Tribler tunnels. However, the max speed is very dependent on your PC’s CPU, as we still process packets in Python. Download speed maxing out at 5.5-6.5 MBytes/s on a fast PC (2.6 GHz Core i7 circa 2018). We still plan to reimplement the Tunnels system in some low-level language this year. Our students started to do that in Rust and almost finished it, but stopped for typical students’ reasons (exams, etc.)


#17

pesky students!! ;p

Hidden mode = anonymous mode. I tried that with 1 hop. It generated some upload bytes, but nothing stable or useful. But something, true.

The CPU part could explain those speeds!! Even more, I’m sure of it that’s the problem.

Seen that neither VPN nor hidden mode solves my upload problem, I’m now looking at a way to bridge my router and work with the hardware I know and love. I’m sure the internet would be plastered with complaints if my ISP really was throttling / capping my torrent traffic.

Thanks, I’ll keep updating for future references - appreciated! ; -)


#18

Might be of interest to other Googlers… Some links!



I haven’t solved my problem yet. When I made sure the CPU never was at 100% usage, my Tribler Linux upload would upload once in a while and some peers could stay connected. Most still keep flashing bye in bursts before disconnecting again. But something happens, some of the time, for the Linux torrent. CPU indeed is a factor. But that won’t explain why my other uploads (utorrent, qbittorent, tribble) refuse to do anything. Even the LAN downloads that were hindering me first don’t work any longer. Weird shit.


#19

Quick update, again : )

I installed Deluge. It helped utorrent to download my torrent!

I downgraded qBittorent to 3.3.16 https://github.com/qbittorrent/qBittorrent/issues/7822

Update: I had uTorrent trying to download my 2nd torrent. It never did. After downgrading qbittorent, quickly enough that torrent was downloaded too…


#20

PS: should I worry about this one? https://canyouseeme.org/ can’t even connect to port 80…?