7.2.1. Crash Report. Help pls


#1

Traceback (most recent call last):
File “TriblerGUI\core_manager.py”, line 114, in on_received_state
RuntimeError: Unhandled Error
Traceback (most recent call last):
File “lib\site-packages\twisted\internet\base.py”, line 428, in fireEvent

File “lib\site-packages\twisted\internet\defer.py”, line 321, in addCallback

File “lib\site-packages\twisted\internet\defer.py”, line 310, in addCallbacks

File “lib\site-packages\twisted\internet\defer.py”, line 653, in _runCallbacks

— —
File “lib\site-packages\twisted\internet\base.py”, line 441, in _continueFiring

File “run_tribler.py”, line 83, in start_tribler

File “Tribler\pyipv8\ipv8\util.py”, line 35, in helper

File “Tribler\pyipv8\ipv8\util.py”, line 47, in blockingCallFromThread

File “Tribler\Core\Session.py”, line 489, in start

File “Tribler\Core\Upgrade\upgrade.py”, line 57, in run

File “Tribler\Core\Upgrade\upgrade.py”, line 68, in upgrade_to_tribler7

File “Tribler\Core\Config\tribler_config.py”, line 89, in write

File “lib\site-packages\configobj.py”, line 2119, in write

exceptions.UnicodeEncodeError: ‘latin-1’ codec can’t encode character u’\u0142’ in position 35: ordinal not in range(256)


#2

@Ramona Thank you for the report. We will look into it.

Have you tried previous versions, for eg 7.2.0? If yes, does it crash as well?


#3

Hello, just discovered tribler and thought i’d give it a shot.

I tried installing and running 7.2.1, 7.2.0-rc1, 7.1.5 and finally 7.0.1 in which i got the UI to startup. All other versions crashed twice while the window with the gears cranked on (behaviour described in other forum posts).

I tried two different magnet links for latest Ubuntu and both statuses are at ‘Building Circuits’. I have two other torrent clients that have been running fine behind my VPN using macOS 10.14.2. No forwarding of ports necessary.

any ideas would be great. i like the look of the app and features look right too. curious to use the channels and see what that’s about.

i hope this bug gets fixed soon!


#4

In previous versions I had the same problem.