7.0.2 Crashes at startup. Stuck at gears turning


#1


#2

Works for me.
The gears did turn for a little while, but then it was up and running.
I have Mac OS High Sierra 10.13


#3

I’m running windows 10. I tried doing a full uninstall then reinstall.


#4

Any Ideas?

INFO 1521407354.70 single_application:23 init()
INFO 1521407354.94 single_application:49 self._outSocket.error() = '2’
INFO 1521407354.94 single_application:60 init(): returning
INFO 1521407360.51 event_request_manager:120 Will connect to events endpoint
INFO 1521407361.65 event_request_manager:43 Got Tribler core error: 2
INFO 1521408285.62 run_tribler:47 Shutting down Tribler


#5

@timmhill Could you try deleting .Tribler directory and run Tribler again, and let us know if it still gets stuck at the gear window?

Also, do you have a large number of downloads? It could be taking time to do a full state check.


#6

I deleted the .Tribler directory first.


#7

I’ve also left it on the loading screen over night.


#8

Got it working after running regedit and deleting all tribler entries.


#9

I’ve had 7.0.2 up and running since it’s release and it hasn’t crashed on me once.


#10

@timmhill It is interesting to know. We delete all the previous registry entries on reinstall so ideally there shouldn’t be any leftover entries. We’ll investigate it more. Thank you for reporting.


#11

@Xyberfaust That’s good to know


#12

Is there a work around for this problem on MacOS? I’ve been trying all week to get anything v7+ working and can’t get it up and running at all. Deleted the .Tribler directory, reinstalled, tried multiple versions. I’m in China using a VPN, and I know that the GFW here is blocking Tor connections, but the VPN should solve that problem. I have three instances of “tribler” running in Activity Monitor, one shows “not responding”.


#13

I’ve got the exact same problem here. I’ve tried uninstalling, deleting all Tribler directories and searching for all Tribler entries in regedit and deleting, shut down the PC and reinstall… It still gets stuck on gears turning. Left it in this state for 48 hours, still turning.
I believe I have either 1 or 2 torrents in my queue.

I’m running Windows 10 64-bit with build 1709.

Any other suggestions?


#14

We just released a new experimental version with several fixes for memory leaks. Please test it out and let us know if you still face this issue.
Tribler v7.1.0-exp2


#15

I’ll try it out. Anything special I should do before installing?


#16

Hi there. Installation was successful but Tribler failed on start up. I used the “Send Report” feature to send the report to your team.


#17

Just to report that I have this working on my Mac now. I don’t know if this was a combination of things that came together or just that I’d never clicked on the icon in the menubar before. I clicked the icon and chose “show downloads” and the main window opened up.

Last night I ran Onyx to clear my caches and rebuild dyld, so that may have helped too. For some reason, Tribler still isn’t automatically going to the torrents lists window tho, I have to select it from the menubar icon.


#18

I am also having the same problem. I’m running Windows 10 64
I’ve also tried uninstall/reinstall and uninstall -reinstall the v7.1.0-exp2 version
continues to just have rolling loading screen…
As I was writing this I just noticed in the DOS window of the expt version there was a problem with a file in C:\Users\User\AppData\Roaming.Tribler
Closed the program and deleted the .Tribler folder
It now works. I include this because in previous posts, I didn’t know what folks meant by the “.TRIBLER” folder. Hope that helps future readers.


#19

Hey! Just wanted to say thanks for the tip Knotworthy. I couldn’t find the .TRIBLER folder either and your tip worked for me. Deleted the folder and am up and running for the first time in a few months.
Thanks!