Tribler on Linux - Dependency is not satisfiable: python-libtorrent


yes, tell it to update sources.list and leave the rest to default values


All right, so I followed the directions and got the apt-build finished (and I had to follow the directions on that blog to keep it from looking at the nonexistent i386 location).

I tried this line as directed in your earlier post:

sudo apt-build --reinstall --target-release testing install python-libtorrent

And this is what I got:

The value 'testing' is invalid for APT::Default-Release as such a release is not available in the sources
Can't call method "packages" on an undefined value at /usr/bin/apt-build line 70.



Oops my bad, mixed up Debian and Ubuntu there, replace testing by trusty


Lol, either way, it gives me the same sort of answer:

The value 'trusty' is invalid for APT::Default-Release as such a release is not available in the sources
Can't call method "packages" on an undefined value at /usr/bin/apt-build line 70.

No idea what to do here.


Meh, let me try with an Ubuntu system to make sure all steps are OK (I was writing from my head but I guess I’m missing something)


Ok, I see what I missed:

When I said to add this to sources.list

I forgot to tell you to add this too:

deb trusty main restricted

DON’T upgrade or install anything else while this line is on your sources.list or your beloved mint will become a broken mint-ubuntu hybrid!

Do an apt-get update, the apt-build install stuff and when python-libtorrent is installed, don’t forget to comment out both lines again.


I did apt-get update and then the apt-build line (used up-arrow to get back to the command), and got this:

python-libtorrent will not be built because it doesn't have a source package.
Missing source package name for source_by_source().

Hmm, I’m quite positive that both lines were valid at the time (I commented them out after I got that error message to be sure I didn’t accidentally install anything else while they were active). Does that mean that somehow python-libtorrent isn’t in the trusty source repo? I’m confused, lol.


I found this PPA from the Deluge guys which contains recent enough libtorrent packages, just add it and forget about the whole apt-build stuff (remember to remove the trusty repos)

Add this to your sources.list
deb precise main

We are using precise here because Mint 13 is based on that Ubuntu release.


OK, so I removed the trusty repos, added that line to the source list, ignored all the warnings of “this hasn’t been verified!” (because apparently it has an issue with the public key), and got the upgraded deluge and python-libtorrent, plus a few new packages.

And I have to laugh, because now it gives me THIS when I try to install (yet another package I don’t have! and this one wasn’t in my package manager at all):

Error: Dependency is not satisfiable: python-pil

So I did a search and found the package listed here.
Better yet, it linked to a PPA that had a precise version of it available.
I figured I’d be able to install it from that.

Unfortunately, this is the error I got when I tried to install it:

Unpacking python-pil (from .../python-pil_2.4.0-1chl1~precise1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/python-pil_2.4.0-1chl1~precise1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/python2.7/dist-packages/PIL/', which is also in package python-imaging 1.1.7-4ubuntu0.12.04.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I got the same error a few min later when my system went “oh, you have an update!” and proceeded to offer python-imaging to me. Then it said python-imaging is broken. (Probably should’ve waited for you to confirm that that was a good idea, lol.) I poked around but if I tried “apt-get install -f” it just wanted to remove calibre and gourmet and a few other things which made me raise my eyebrows so I didn’t go ahead with that. It seems to have fixed itself after installing a few other libraries (and uninstalling/reinstalling it), though, so I’m back to what I had before: python-imaging v1.17 installed when python-pil appears to need v2.4 or something like that. (I wonder what would happen if I uninstalled python-imaging, re-enabled the PPA, then tried installing python-pil? Won’t try it but am curious if that would work.)

So now I’m stuck again, lol. (Thanks for being so patient!)


That error means that python-pil contains files that overlap with the contents of python-imaging. I don’t know what packages depend on python-imaging on your system, but I would guess a handful of them and uninstalling it would remove them.

I see two options here:

  • Update to the next Mint.
  • Try to run Tribler directly from a git clone (Instructions on how to do so are in our README file here). Dependency versions will not be checked this way. But be aware that we had to push up the minimum libtorrent version due to bugs in the library and I don’t remember if that implied API changes too. So no guarantee this would work either…


Yeah, this is the list it was going to remove (I didn’t think I really wanted to do that):

calibre gourmet hplip mint-meta-mate mintinstall printer-driver-postscript-hp python-imaging

Alas, it just throws up an error in the middle, after cloning it correctly and running the script in terminal:

ImportError: No module named requests

Also assuming I shouldn’t try the method instructed in the FAQ, installing Tribler despite dependency issues? We were working more on trying to resolve the dependencies, didn’t try that.

I guess I’ll have to wait till I get a chance to upgrade my Mint. (It’s a bit of a complicated situation, with the number of Windows programs I’ve had to run with Wine–and have custom-created shortcuts in a special bar in addition to my taskbar, an upgraded kernel to avoid a bug with Ivybridge mobo, several special PPas for specific programs, etc. And then there’s backups of data to run . . .) Will take too long at one time to do it except on a long holiday and the first I get with nothing else I have to do is next June. :frowning:

Thanks for trying to help. I guess should maybe put up some notice on the site somewhere that Ubuntu 12.04 is not supported? Just in case anyone else tries the same thing.


Well, at least that one is easy to fix: sudo apt-get install python-requests :slight_smile:


Lol, but then it gets to this:

  File "/home/destiny/tribler/Tribler/Core/Video/", line 10, in <module>
    from PIL import Image
ImportError: No module named PIL

I’m thinking that given that I can’t seem to install python-pil, that I probably won’t have any luck with this then.

(On a side note, apparently it actually did uninstall those packages I listed, even though I don’t believe I gave it permission–must have misunderstood–so I had to reinstall them.)


If you removed all the PPA’s you added, you should be able to install upstream’s python-pil with no issues. If you can’t then I guess it’s packaging bug.

Maybe you can work arond it by installing it via pip? pip install --user --upgrade pillow

Note: No sudo here.


Hmm, apt-cache search does not return anything named python-pil if I don’t have that PPA added. I don’t think it’s in the 12.04 repos, only PPAs.

That command tells me I also don’t have pip installed–should I?


Yes, install it if it’s not there.


The output of that was too large to stay all available on the terminal screen, but here’s where things started to go wrong: pastebin output

It sent all of it to a log, should I upload the contents of that somewhere?


It’s missing the python header: Python.h: No such file or directory , so you need to install libpython2.7-dev

(Sorry for the delay, I just came back from vacation)


Tried getting it with apt-get in the terminal; it can’t find that package. Not available for my distro version, maybe?

(Sorry for MY late reply–work has been absolutely insane lately, very little time at home.)


Could be you 12.04 is at python 2.6? If it is, I’m afraid we don’t support it anymore (It may still work)

Try installing libpython2.6-dev