Tribler 7 release candidate 2 - Please test


#21

Traceback (most recent call last):
File “run_tribler.py”, line 21, in
File “TriblerGUI\tribler_window.py”, line 103, in init
File “lib\site-packages\PyQt5\uic_init_.py”, line 224, in loadUi
File “lib\site-packages\PyQt5\uic\Loader\loader.py”, line 72, in loadUi
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 949, in parse
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 774, in createUserInterface
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 752, in traverseWidgetTree
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 226, in createWidget
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 752, in traverseWidgetTree
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 463, in createLayout
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 752, in traverseWidgetTree
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 506, in handleItem
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 752, in traverseWidgetTree
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 463, in createLayout
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 752, in traverseWidgetTree
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 506, in handleItem
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 752, in traverseWidgetTree
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 226, in createWidget
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 752, in traverseWidgetTree
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 217, in createWidget
File “lib\site-packages\PyQt5\uic\uiparser.py”, line 178, in setupObject
File “lib\site-packages\PyQt5\uic\objcreator.py”, line 106, in createQObject
File “lib\site-packages\PyQt5\uic\objcreator.py”, line 131, in findQObjectType
File “lib\site-packages\PyQt5\uic\Loader\qobjectcreator.py”, line 118, in search
ImportError: unable to import module TriblerGUI.widgets.trustpage

I don’t use tribler 7 -> windows 8.1
fast modify please


#22

Indeed Tribler does not good work with Windows 8.1.

For a while, Tibler worked well, suddenly the problem that i can’t add torrent files and magnet-links any more, Not even from the own Tribler library.

Later Tribler do not want to start anymore, it is sticks in the dark gray screen with the orange gears. After that shut down and an Error message in the desktop.

I use now Tribler 6.5.2 but it works stabile so slowly. 3 / 4 kb/s to 80 kb/s. Sometime it takes 4 days for downloading one movie.

I wonder if the Tribler team have test Tribler on a Windows 8.1 computer?

The highest time for a error Repair round.


#23

Thank you for your reports but unfortunately, we are busy and understaffed. We appreciate your patience and we will try to polish and bug-fix as soon as we can but at the moment, we have to prioritize some other things first.


#24

Thank you for your response.

Tribler is a project run by volunteers. I am patient, i work for the time being with the stable working version 6.5.2.

Everything need its time.

I’m not negative I’m trying to help my way. I am pleased that there are people who are committed to this important project.

Here a new Error message. Hopefully you can do something with it.

Warning: option --plugin-path no longer exists.
Warning: option --plugin-path no longer exists.
QSslSocket: cannot resolve TLSv1_1_client_method
QSslSocket: cannot resolve TLSv1_2_client_method
QSslSocket: cannot resolve TLSv1_1_server_method
QSslSocket: cannot resolve TLSv1_2_server_method
Unhandled Error
Traceback (most recent call last):
File “lib\site-packages\twisted\internet\base.py”, line 417, in fireEvent
File “lib\site-packages\twisted\internet\defer.py”, line 317, in addCallback
File “lib\site-packages\twisted\internet\defer.py”, line 306, in addCallbacks
File “lib\site-packages\twisted\internet\defer.py”, line 649, in _runCallbacks
— —
File “lib\site-packages\twisted\internet\base.py”, line 430, in _continueFiring
File “TriblerGUI\core_manager.py”, line 60, in start_tribler
File “Tribler\dispersy\util.py”, line 46, in helper
File “Tribler\dispersy\util.py”, line 225, in blockingCallFromThread
File “Tribler\Core\Session.py”, line 558, in start
File “Tribler\Core\APIImplementation\LaunchManyCore.py”, line 178, in register
File “Tribler\Core\APIImplementation\LaunchManyCore.py”, line 298, in init
File “Tribler\dispersy\util.py”, line 46, in helper
File “Tribler\dispersy\util.py”, line 225, in blockingCallFromThread
File “Tribler\Core\Libtorrent\LibtorrentMgr.py”, line 70, in initialize
File “Tribler\Core\Libtorrent\LibtorrentMgr.py”, line 193, in get_session
File “Tribler\Core\Libtorrent\LibtorrentMgr.py”, line 157, in create_session
File “Tribler\Core\Libtorrent\LibtorrentMgr.py”, line 202, in set_proxy_settings
exceptions.TypeError: int() argument must be a string or a number, not 'NoneType
ERROR:root:Traceback (most recent call last):
File “TriblerGUI\core_manager.py”, line 133, in on_received_state
RuntimeError: Unhandled Error
Traceback (most recent call last):
File “lib\site-packages\twisted\internet\base.py”, line 417, in fireEvent
File “lib\site-packages\twisted\internet\defer.py”, line 317, in addCallback
File “lib\site-packages\twisted\internet\defer.py”, line 306, in addCallbacks
File “lib\site-packages\twisted\internet\defer.py”, line 649, in _runCallbacks
— —
File “lib\site-packages\twisted\internet\base.py”, line 430, in _continueFiring
File “TriblerGUI\core_manager.py”, line 60, in start_tribler
File “Tribler\dispersy\util.py”, line 46, in helper
File “Tribler\dispersy\util.py”, line 225, in blockingCallFromThread
File “Tribler\Core\Session.py”, line 558, in start
File “Tribler\Core\APIImplementation\LaunchManyCore.py”, line 178, in register
File “Tribler\Core\APIImplementation\LaunchManyCore.py”, line 298, in init
File “Tribler\dispersy\util.py”, line 46, in helper
File “Tribler\dispersy\util.py”, line 225, in blockingCallFromThread
File “Tribler\Core\Libtorrent\LibtorrentMgr.py”, line 70, in initialize
File “Tribler\Core\Libtorrent\LibtorrentMgr.py”, line 193, in get_session
File “Tribler\Core\Libtorrent\LibtorrentMgr.py”, line 157, in create_session
File “Tribler\Core\Libtorrent\LibtorrentMgr.py”, line 202, in set_proxy_settings
exceptions.TypeError: int() argument must be a string or a number, not ‘NoneType’


#25

I cleared Tribler install (deleted download directory, and the hidden .Tribler folder)
After importing few magnets, the same error message every time on start:
(OS is Ubuntu the last release)

Traceback (most recent call last):
File “/usr/share/tribler/TriblerGUI/core_manager.py”, line 133, in on_received_state
raise RuntimeError(state[‘last_exception’])
RuntimeError: Unhandled Error
Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/twisted/internet/base.py”, line 417, in fireEvent
DeferredList(beforeResults).addCallback(self._continueFiring)
File “/usr/lib/python2.7/dist-packages/twisted/internet/defer.py”, line 317, in addCallback
callbackKeywords=kw)
File “/usr/lib/python2.7/dist-packages/twisted/internet/defer.py”, line 306, in addCallbacks
self._runCallbacks()
File “/usr/lib/python2.7/dist-packages/twisted/internet/defer.py”, line 588, in _runCallbacks
current.result = callback(current.result, *args, **kw)
— —
File “/usr/lib/python2.7/dist-packages/twisted/internet/base.py”, line 430, in _continueFiring
callable(*args, **kwargs)
File “/usr/share/tribler/TriblerGUI/core_manager.py”, line 60, in start_tribler
session.start()
File “/usr/share/tribler/Tribler/dispersy/util.py”, line 46, in helper
return blockingCallFromThread(reactor, func, *args, **kargs)
File “/usr/share/tribler/Tribler/dispersy/util.py”, line 225, in blockingCallFromThread
return f(*args, **kwargs)
File “/usr/share/tribler/Tribler/Core/Session.py”, line 558, in start
startup_deferred = self.lm.register(self, self.sesslock)
File “/usr/share/tribler/Tribler/Core/APIImplementation/LaunchManyCore.py”, line 178, in register
self.init()
File “/usr/share/tribler/Tribler/Core/APIImplementation/LaunchManyCore.py”, line 298, in init
self.ltmgr.initialize()
File “/usr/share/tribler/Tribler/dispersy/util.py”, line 46, in helper
return blockingCallFromThread(reactor, func, *args, **kargs)
File “/usr/share/tribler/Tribler/dispersy/util.py”, line 225, in blockingCallFromThread
return f(*args, **kwargs)
File “/usr/share/tribler/Tribler/Core/Libtorrent/LibtorrentMgr.py”, line 70, in initialize
self.get_session().start_upnp()
File “/usr/share/tribler/Tribler/Core/Libtorrent/LibtorrentMgr.py”, line 193, in get_session
self.ltsessions[hops] = self.create_session(hops)
File “/usr/share/tribler/Tribler/Core/Libtorrent/LibtorrentMgr.py”, line 157, in create_session
self.set_proxy_settings(ltsession, *proxy_settings)
File “/usr/share/tribler/Tribler/Core/Libtorrent/LibtorrentMgr.py”, line 202, in set_proxy_settings
proxy_settings.port = int(server[1])
exceptions.TypeError: int() argument must be a string or a number, not ‘NoneType’


#26

I had this same issue with 6.5.2. as well, so this isn’t 7RC2-specific, but it seemed to work fine for me for a while after installation (I think it’s been a few months since I installed 7RC2) and now when I boot it up it gets stuck on ‘Building Circuits’ and remains at 0%. I’ve even uninstalled and reinstalled it and it’s still stuck on Building CIrcuits at 0%.

I’m using Windows 10, btw.

I get this message in the log window every time I open up Tribler but I was getting this exact same message while it was still working so I’m not sure what it means:


Qt: Untested Windows version 10.0 detected!
Warning: option --plugin-path no longer exists.
Warning: option --plugin-path no longer exists.
QSslSocket: cannot resolve TLSv1_1_client_method
QSslSocket: cannot resolve TLSv1_2_client_method
QSslSocket: cannot resolve TLSv1_1_server_method
QSslSocket: cannot resolve TLSv1_2_server_method
Qt: Untested Windows version 10.0 detected!


#27

This will be fixed in the next release, together with many other minor issues :slight_smile:


#28

New user here, using windows 7, 64 bit. After installing the 64 bit version, it worked once, the second time opening Tribler i got the error message below, after removing the 64 bit and installing the 32 bit version i got the same error.

Traceback (most recent call last):
File “TriblerGUI\core_manager.py”, line 133, in on_received_state
RuntimeError: Unhandled Error
Traceback (most recent call last):
File “lib\site-packages\twisted\internet\base.py”, line 417, in fireEvent

File “lib\site-packages\twisted\internet\defer.py”, line 317, in addCallback

File “lib\site-packages\twisted\internet\defer.py”, line 306, in addCallbacks

File “lib\site-packages\twisted\internet\defer.py”, line 649, in _runCallbacks

— —
File “lib\site-packages\twisted\internet\base.py”, line 430, in _continueFiring

File “TriblerGUI\core_manager.py”, line 60, in start_tribler

File “Tribler\dispersy\util.py”, line 46, in helper

File “Tribler\dispersy\util.py”, line 225, in blockingCallFromThread

File “Tribler\Core\Session.py”, line 558, in start

File “Tribler\Core\APIImplementation\LaunchManyCore.py”, line 178, in register

File “Tribler\Core\APIImplementation\LaunchManyCore.py”, line 298, in init

File “Tribler\dispersy\util.py”, line 46, in helper

File “Tribler\dispersy\util.py”, line 225, in blockingCallFromThread

File “Tribler\Core\Libtorrent\LibtorrentMgr.py”, line 70, in initialize

File “Tribler\Core\Libtorrent\LibtorrentMgr.py”, line 193, in get_session

File “Tribler\Core\Libtorrent\LibtorrentMgr.py”, line 157, in create_session

File “Tribler\Core\Libtorrent\LibtorrentMgr.py”, line 202, in set_proxy_settings

exceptions.TypeError: int() argument must be a string or a number, not ‘NoneType’


#29

Hi, thank you for your report. This is a known issue and will be solved in the next release of Tribler. For now, you could use an older version.


#30

Love Tribler: Tried THIS 7. Nothing downloading at all eve, That’s terrible.
However KUDOS to the ART teams !!!
IT SURE LOOKS PRETTY or COOL / Whatever. I’d like it to function please.
Tried running it on an older circa 2007 1.99Ghz Dual Pentium AOPEN (amazing earlier blazer PC) 941-ish I think. THANK YOU FOR ALL EFFORTS, but this sucks so far, please keep the clean-up effort going ! ! !
Heading back to yer older functional and UGLY stuff. 652 …veeeerrrryyyyry slow,
but functioNall ! Still hoping to open ALL firewalls jus’ fer TriBlurr in my personal chain to the inet.
Failing forward is not a disgrace, it is an amazing effort that is not yet finished… Keep going ! ! !


#31

installer crashed at point where it tried to install vlc.


#32

Do you have some more details about the specific error that occurred (i.e. a screenshot)? This helps us to debug this.


#33

Tried to use the candidate. But it says (in command line mode): Qt: Untested version Windows 10.0 detected!
Due to my latest Windows update?
I’m using Windows 10 Pro. Build 15063.608.


#34


#35

@venttoux we will release a new version in a few days which is compiled with a newer version of our graphical user interface framework. In this new version, this should be resolved. :slight_smile: