How do I seed?!?! (SOLVED)


I promise I searched the forums, but all the screenies seem to be from an older version of Tribler, the new interface is apparently different.

I drop the files in my channel and the only option is to download. I try downloading and it searches forever for the meta data. I drop a bittorrent file containing the seed into the destination folder and no luck. I drop the literal file I’m trying to seed into the folder and still no luck.

I stop, restart, I even tried Seeding on bit torrent to get the file started. Still Tribler insists that there’s no meta data to be had.

What do you want from me Tribler?!?!

EDIT: Hours later it suddenly downloaded and began seeding. I know not what dark magics caused this. But then I played with the browse button and found another-another way.

For future confused people:


I thought I was seeding but

It seems our GUI design is not clear.
Please, tell us how you expected it to work when you first saw it, and how you would prefer it to work.

Your feedback is really appreciated.


If I may hook on to this thread, whenever I create a torrent this way, it starts seeding non-anonymously by default. I would prefer it to start seeding anonymously.


Thank you for clearly explaining our GUI deficiencies.

Currently we’re 10 development engineers. I’m leaning towards hiring a dedicated phd student for the user interaction design. Thus for 4 years we will gradually improve the clarity and no-manual-needed level of Tribler. See work of our prior dedicated GUI scientist: (100MByte .PDF)