Checkpointing downloads fails


This happens on My Lenovo laptop with Windows 7.


Thanks, 7.4.0 seems to have a lot of the kinks straightened out


not for me, still the same behaviour in 7.4.0


7.4.1 just surfaced

download that and try it out, I am downloading it now


This error means there is an offending (broken) checkpoint file in your “dlcheckpoints” folder in Tribler state dir. If you could send us the offending file, that will help us greatly to debug the issue.


just updated to 7.4.1 and will see how this behaves now.
where can i find that file? running currently on windows

still the same behaviour


On Windows, the Tribler directory is located in your Users dir. The path should be something like:

c:\users\<Your Username>\appdata\Roaming\.Tribler\7.4.X\dlcheckpoints — new version (7.4.X and later )
c:\users\<Your Username>\appdata\Roaming\.Tribler\dlcheckpoints — older versions (7.3.2 and earlier)

Note that appdata dir is a hidden one, so you should either enable Show hidden files and dirs in Explorer, or enter the path directly in Explorer’s address bar.
dlcheckpoints dir contains *.conf files - these are all your saved downloads.

If you don’t mind the privacy issue, send them all to us :wink:


i use tribler only to download some audio files, so i dont mind the privacy issue that much as this is legal in my country :slight_smile:


what i noticed: i have a lot of .conf files, i guess most of them are because of mining. i only downloaded maybe 5 or 6 discographies, expecting only 5-6 *.conf files


have you been able to check those files?


Yep, we used your files to fix the issue today for 7.4.2 release. Thanks!


i just installed 7.4.2 but now my downloads are gone…? i dont see them anymore. my balance is also 0.0 MB


There is an error in the upgrade procedure, it was reported a few minutes ago. We are working on a hotfix now, it will be released today.

What version did ran last before upgrading to 7.4.2 ?


BTW, don’t worry, your balance/downloads/DB are fine. You just need to go to the earlier version of Tribler (like 7.4.1).


7.4.1 was running before the upgrade


i upgraded now to tribler 7.4.3 but again: all downloads are gone, no token balance ?!

i really appreciate your work, but i am wondering why this software is so buggy (no unit tests/test driven, no e2e tests, no QA?) ? because i really like the idea behind it


If you tried 7.4.2 and lost your balance/downloads, please look at for the explanation on what happened and how to fix it.

If you did something like 7.4.1->7.4.2->7.4.3 you will still have no balance and have to apply the manual fix described on the wiki. One could say that 7.4.2 “infected” the state dir. To fix the problem, you have to clean it up manually. Introducing an automated fix for that would overcomplicate the upgrade process and attract even more bugs in the future. Also, only about 100 people downloaded the 7.4.2 before we took it down after the reports. Basically, users who reported the problem saved everyone else.

Regarding our recent release quality, remind that Tribler is a non-commercial software funded by academic grants. At the moment, the Tribler team includes only a couple of full-time professional developers that are busy refactoring the codebase that is 14 years of experimental stuff written mostly by students and PhDs. So, we have to prioritize…

Recently, we got a big grant so we hope to hire more professional full-time developers this year. However, this takes time. Talent is hard to find and we can’t offer people the same level of salary as e.g. Google or Facebook.

Nonetheless, we’re dedicated to the ideas of privacy and free information exchange. Stay tuned, and again, thanks for timely reports. These days we have to rely on our users’ community more than ever. :+1:


i tried first to set last_version to 7.4.2, then started tribler. same result (no downloads).
then i deleted the file and started tribler 7.4.3 - no downloads.
do i have to first install 7.4.2? in the documentation (your link) is no information what to do when the updated from 7.4.2->7.4.3 already happened. only that before any update is done, one should modify/delete the file. but what to do when it was installed?


I updated the wiki page with instructions for people who already updated 7.4.2->7.4.3. Basically, you have to delete 7.4.3 sub-directory in .Tribler dir and apply the same steps (e.g. change your last_version to either 7.4.0 or 7.4.1 or delete version_history.json).


deleting 7.4.3-subdirectoy worked, thanks