Can't install Tribler 6.5.2 in Ubuntu 16.04: Package python-wxgtk2.8 is not installed


#1

Hello,

I had Tribler working in the previous Ubuntu version.

Now I can’t install it. This is the “dpkg -i tribler_6.5.2_all.deb” output:

Selecting previously unselected package tribler.
(Reading database ... 225603 files and directories currently installed.)
Preparing to unpack tribler_6.5.2_all.deb ...
Unpacking tribler (6.5.2) ...
dpkg: dependency problems prevent configuration of tribler:
 tribler depends on python-wxgtk2.8; however:
  Package python-wxgtk2.8 is not installed.

dpkg: error processing package tribler (--install):
 dependency problems - leaving unconfigured
Processing triggers for gconf2 (3.2.6-3ubuntu6) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
 tribler

The problem is that

python-wxgtk2.8
doesn’t exist in this Ubuntu version. It does exist python-wxgtk3.0 and it is installed.

What can I do?

Best Regards,


#2

You must update the python with the last version. I has the same issu here.


#3

I have the same exact problem … tribler will not install since i upgraded ubuntu to 16.04 … it gives the message that dependency not satisfied and it wants python-wxgtk2.8 … however this ubuntu only has python-wxgtk3.0 and no others in the repositories … any ideas?


#4

Could you try if this works for you and report problem or success please?

https://github.com/Tribler/tribler/blob/devel/doc/Tribler%20development%20on%20Linux.md#experimental-support-for-ubuntu-1604


#5

I had the same probl, but got it fixed, this is how;
Running Ubuntu 16.04 and
Tribler from the link given by Root above (tribler_6.6.0-pre-exp_all.deb)

steps i toke;

  1. sudo apt-get install libsodium-dev python-nacl python-nacl python-nacl

  2. Google libsodium13 for ubuntu 16.04 and download libsodium13_1.0.3-1_amd64.deb
    install ; sudo dpkg -i lib…

  3. Google python-cryptography for ubuntu 16.04 and download python-cryptography-1.2.3-1
    install ; sudo dpkg -i pyth…
    you probably be missing a lot of packages and will get missing packages error’s
    than do
    sudo apt-get -f install
    afterwards to get the missing packages installed.
    than try to install again;
    install ; sudo dpkg -i pyth…

  4. and now install tribler_6.6.0-pre-exp_all.deb

    sudo dpkg -i tribler…

this worked for me!
Best regards


#6

Using your experimental build the installation works.


#7

I run with command in ubuntu
$ ./tribler.sh
it run ok !


#8

I’m using Ubuntu 16.10 and with my utmost regret this doesn’t work for me, when I try to run it this appears:


#9

This is in Lubuntu 16.04

root@uindocs11:/home/l1604/Templates# dpkg -i *.deb
Selecting previously unselected package tribler.
(Reading database … 250157 files and directories currently installed.)
Preparing to unpack tribler_6.5.2_all.deb …
Unpacking tribler (6.5.2) …
dpkg: dependency problems prevent configuration of tribler:
tribler depends on libjs-excanvas; however:
Package libjs-excanvas is not installed.
tribler depends on libjs-mootools; however:
Package libjs-mootools is not installed.
tribler depends on python-decorator; however:
Package python-decorator is not installed.
tribler depends on python-gmpy; however:
Package python-gmpy is not installed.
tribler depends on python-leveldb; however:
Package python-leveldb is not installed.
tribler depends on python-libtorrent (>= 0.16.4); however:
Package python-libtorrent is not installed.
tribler depends on python-m2crypto; however:
Package python-m2crypto is not installed.
tribler depends on python-requests; however:
Package python-requests is not installed.
tribler depends on python-wxgtk2.8; however:
Package python-wxgtk2.8 is not installed.

dpkg: error processing package tribler (–install):
dependency problems - leaving unconfigured
Processing triggers for gconf2 (3.2.6-3ubuntu6) …
Processing triggers for man-db (2.7.5-1) …
Processing triggers for desktop-file-utils (0.22-1ubuntu5) …
Processing triggers for mime-support (3.59ubuntu1) …
Errors were encountered while processing:
tribler
root@uindocs11:/home/l1604/Templates# apt-get install -f
Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following packages were automatically installed and are no longer required:
libjs-excanvas libjs-mootools libleveldb1v5 python-decorator python-gmpy
python-leveldb python-libtorrent python-m2crypto python-ndg-httpsclient
python-requests python-urllib3
Use ‘sudo apt autoremove’ to remove them.
The following additional packages will be installed:
libjs-excanvas libjs-mootools libleveldb1v5 python-decorator python-gmpy
python-leveldb python-libtorrent python-m2crypto python-ndg-httpsclient
python-requests python-urllib3
Suggested packages:
python-ntlm
The following packages will be REMOVED:
tribler
The following NEW packages will be installed:
libjs-excanvas libjs-mootools libleveldb1v5 python-decorator python-gmpy
python-leveldb python-libtorrent python-m2crypto python-ndg-httpsclient
python-requests python-urllib3
0 upgraded, 11 newly installed, 1 to remove and 3 not upgraded.
1 not fully installed or removed.
Need to get 1.269 kB of archives.
After this operation, 1.119 kB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.
root@uindocs11:/home/l1604/Templates#


#10

The wx dependency is removed in Tribler 7 so this issue is not relevant anymore when we release it.