7.5.4 crash issue (Linux,Windows,Mac)


#1

I’m using Tribler on a lightweight Debian/Ubuntu based OS, inside of Virtualbox. I’ve tried two different operating systems (Peppermint OS & LXLE OS) and I get the same error. It installs and launches okay but within several minutes, Tribler will crash with the following error:

Traceback (most recent call last):
File “/usr/share/tribler/TriblerGUI/event_request_manager.py”, line 114, in on_read_data
raise RuntimeError(json_dict[“event”][“text”])
RuntimeError: [Failure instance: Traceback: <class ‘ValueError’>: Invalid secret key
/usr/share/tribler/Tribler/pyipv8/ipv8/messaging/anonymization/community.py:74:inner_wrapper
/usr/share/tribler/Tribler/pyipv8/ipv8/messaging/anonymization/community.py:749:on_create
/usr/share/tribler/Tribler/pyipv8/ipv8/util.py:76:addCallback
/usr/lib/python3/dist-packages/twisted/internet/defer.py:310:addCallbacks
— —
/usr/lib/python3/dist-packages/twisted/internet/defer.py:653:_runCallbacks
/usr/share/tribler/Tribler/pyipv8/ipv8/messaging/anonymization/community.py:745:determined_to_join
/usr/share/tribler/Tribler/community/triblertunnel/community.py:458:join_circuit
/usr/share/tribler/Tribler/pyipv8/ipv8/messaging/anonymization/community.py:717:join_circuit
/usr/share/tribler/Tribler/pyipv8/ipv8/messaging/anonymization/tunnelcrypto.py:46:generate_diffie_shared_secret
/home/zeno/.local/lib/python3.6/site-packages/libnacl/init.py:873:crypto_auth
]


#2

We are seeing a packet-of-death incident on our network. “Stable Tribler” will crash in seconds or minute after startup. Thank you for reporting this! This crash seems the result of a single incoming packet :frowning:

Sadly all stable 7.5.4 releases seem affected (Windows,Linux,Mac). The latest 7.6.0-exp1 experimental release seems to fix this issue. We’re escalation the release to address this issue.

Apologies, we should have caught this!
We transitioning from an academic team towards “critical infrastructure quality”. However, we’ve got much to learn. Delft University greetings, johan.


#3

I have same problem since 4 days . When I want to start Tribler after 1 minutes I experience “unexpected error” as follow:
Traceback (most recent call last):
File “src\tribler-gui\tribler_gui\event_request_manager.py”, line 116, in on_read_data
RuntimeError: ord() expected string of length 1, but int found
–LONG TEXT–
Traceback (most recent call last):
File “lib\asyncio\events.py”, line 81, in _run
File “lib\asyncio\selector_events.py”, line 1019, in _read_ready
File “ipv8\messaging\interfaces\udp\endpoint.py”, line 35, in datagram_received
File “ipv8\messaging\interfaces\endpoint.py”, line 85, in notify_listeners
File “ipv8\messaging\interfaces\endpoint.py”, line 73, in _deliver_later
File “ipv8\community.py”, line 338, in on_packet
TypeError: ord() expected string of length 1, but int found

–CONTEXT–
{‘message’: ‘Exception in callback _SelectorDatagramTransport._read_ready()’, ‘exception’: TypeError(‘ord() expected string of length 1, but int found’), ‘handle’: <Handle _SelectorDatagramTransport._read_ready()>}


#4

I appreciate your attention to this Johan. I’ve been running 7.6.0-exp1 for several hours without issue now. And while we don’t have a lot of incentive to express it, I think a lot of us are deeply appreciative of all the efforts by the devs. This is the best looking torrent client and the best looking of all Linux apps and we do notice the steady improvements.