Downloading/Seeding?

Comments and or questions about Tribler

Downloading/Seeding?

Postby susie » Sun Feb 19, 2012 8:46 pm

Hi Everyone!

So I've got Tribler set up and working (at least I think it's working). It shows my channel, it shows all my created torrents as finished downloading and now seeding, etc. However, I'm not sure that anyone can actually *get* them, nor can I seem to download files from others. I have left all settings at their default...the port being used is 7760 (which is the default Tribler picked, i guess), but the smiley face is straight-faced...not smiling or frowning.

I tried to download a torrent from another user, and it never started. It said I was d/l the torrent, but no progress ever began after over an hour. All the numbers along the bottom (sharing rep, upload, download) are still 0. I guess my question is...how do I know if everything is set so that files can be downloaded, and that my created torrents are actually being shared? How do I get that smiley face to smile? lol I've allowed Tribler through the firewall, but that doesn't seem to be all I need to do.

I guess I'm not sure if I'm actually sharing anything, and it doesn't seem as though I can actually download from others, either.

Help? lol

Thanks!
"This one time, at band camp..."
User avatar
susie
Visitor
 
Posts: 23
Joined: Tue Feb 14, 2012 8:25 pm
Location: California

Re: Downloading/Seeding?

Postby susie » Sun Feb 19, 2012 11:20 pm

UPDATE: ok, the 1 file that I was trying to download finally downloaded, I guess...but now when I look at the bottom, it says my sharing reputation is "poor"??? wth?? I have like 177 torrents that I created and am trying to share, it says they're seeding...what am I doing wrong? I don't wanna have a poor sharing rep, I really wanna share the files I have, and I thought I was! :-(

Can anyone give me some advice or suggestions? Tribler seemed so easy to begin with, but now I'm not so sure...I wish there was step-by-step instructions or something...

and the smiley face is still straight-faced

Thanks in advance
"This one time, at band camp..."
User avatar
susie
Visitor
 
Posts: 23
Joined: Tue Feb 14, 2012 8:25 pm
Location: California

Re: Downloading/Seeding?

Postby Niels » Mon Feb 20, 2012 9:49 am

The straight-faced smiley face is trying to tell you to open your Internet connection.
This is usually done by setting up port forwarding in your router. Without it seeding becomes much more difficult.

A site which explains how to do this well is http://portforward.com/, but be carefull to not install any spyware.
After selecting your router, the page shown is actually an add. Click the 'Click here to skip this advertisement...' text located in the upper right corner to proceed to the actual manual.
Niels
Addict
 
Posts: 718
Joined: Mon Aug 23, 2010 1:56 pm

Re: Downloading/Seeding?

Postby susie » Mon Feb 20, 2012 11:36 am

hi niels,

sorry for the delay in replying..i'll give this all a try tomorrow (later today) when I have a fresh mind. just got off work and not motivated enough atm lol

i'll get back to ya and let ya know how it works out...

thanks!
"This one time, at band camp..."
User avatar
susie
Visitor
 
Posts: 23
Joined: Tue Feb 14, 2012 8:25 pm
Location: California

Re: Downloading/Seeding?

Postby Migratory » Mon Feb 20, 2012 9:23 pm

I have that line-mouthed smiley as well, I set my router (a D-link DIR-825) to forward port 7760 for both TCP and UDP and the smiley hasn't changed. Everything works fine except I can't upload.
Migratory
Visitor
 
Posts: 6
Joined: Mon Feb 20, 2012 9:14 pm

Re: Downloading/Seeding?

Postby Migratory » Mon Feb 20, 2012 9:49 pm

Update: Flat smiley is still there, but Tribler managed to squeeze out one MB in the past twenty minutes. So it seems capable of uploading, it just does so very infrequently.
Migratory
Visitor
 
Posts: 6
Joined: Mon Feb 20, 2012 9:14 pm

Re: Downloading/Seeding?

Postby susie » Mon Feb 20, 2012 10:10 pm

ok niels,

i went thru the whole port forwarding stuff, got everything set up as it should be, and I still have a straight-faced guy..no smile. And I don't know as of yet if I'm capable of uploading anything...

when does the face start to smile? lol

thanks for the help :-)
"This one time, at band camp..."
User avatar
susie
Visitor
 
Posts: 23
Joined: Tue Feb 14, 2012 8:25 pm
Location: California

Re: Downloading/Seeding?

Postby Migratory » Tue Feb 21, 2012 4:55 am

I think I've found a clue. I kept Tribler going since I first posted this morning and I kept the peers tab of a seeding torrent open. Through out the day I would continuously connect to peers, only to have them disappear in a few seconds. However, every time I connected to a peer running BitTorrent 7 (I've seen BitTorrent 7.5 as well as BitTorrent 7.6) I stay connected to them and seed normally. The smiley stays strait-faced the whole time. I hope this helps.
Migratory
Visitor
 
Posts: 6
Joined: Mon Feb 20, 2012 9:14 pm

Re: Downloading/Seeding?

Postby Uffowich » Tue Feb 21, 2012 8:14 am

I've noticed something, don't know if it has anything to do with this problem though, but it could...

I've set port 7760 in the settings of Tribler. I've opened this port in the firewall (right now I'm running over a VPN though, so all ports should be OK), but when I click on the badge to get info on Tribler, the ports mentioned there on the WAN and LAN isn't 7760, but 7759. I've opened this port too, just to make sure.

But either it's a bug in the info-window (clicking on the badge), or it's not using the port set in the configuration.
Uffowich
Visitor
 
Posts: 78
Joined: Mon Feb 13, 2012 10:40 am

Re: Downloading/Seeding?

Postby susie » Tue Feb 21, 2012 9:39 am

I kept tribler on all day today and either i'm offering stuff nobody wants (which i know i'm not), or people simply cannot connect/i cannot upload...i finally shut it off out of sheer frustration. i mean, what's the point if all i can do is take from others and have a poor sharing rep?

i'm really computer-illerate when it comes to this torrenting stuff, and it seemed as though tribler would be easy for a dip-stick like myself to use and share, but, i guess it really isn't. i don't understand all the port-forwarding stuff that was necessary, but i made my poor husband do everything it said to do, i've sat here and created over 100 torrents to share, and for what? it still isn't working.

don't mean to come off as a whiner, i'm just really frustrated. thanks to all who've replied here, but sadly, it just isn't working out for me.

on a side note, or maybe more connected than i realize...i am using tribler version 11, which i guess is not the most current version. could that be related somehow? if i install the newer version, will i lose anything (my channel, favorites, etc), will i have to d/l all those collected torrents again?

thanks again for all y'all's help, and i apologize for the lack of capital letters, i'm tired lol
"This one time, at band camp..."
User avatar
susie
Visitor
 
Posts: 23
Joined: Tue Feb 14, 2012 8:25 pm
Location: California

Re: Downloading/Seeding?

Postby Niels » Tue Feb 21, 2012 10:09 am

Upgrading to a newer version will not cause you to lose all your torrents etc.
Opening TCP port 7760 should be enough to make Tribler work. Are you sure that you do not have a firewall somewhere as well?
Susie I can imagine your frustration, Tribler at the moment is I guess not ready for 'normal' users. It should work, but it depends on a lot of factors. One would be that users first need to find your channel, if they don't then they will never download your torrents.

The WanLan thing Uffowich is mentioning is our new UDP based protocol which should not have any problems automatically breaking through your nat-router.
Niels
Addict
 
Posts: 718
Joined: Mon Aug 23, 2010 1:56 pm

Re: Downloading/Seeding?

Postby susie » Tue Feb 21, 2012 10:59 am

hi Niels,

Regarding the firewall, I'm using the windows 7 firewall, and I've gone into the settings and set it to allow Tribler through, so I'm pretty sure my issue isn't firewall-related, but again, I'm not a whiz with this stuff lol

It looks as though a few users have found my channel, as it says that it's been marked as a favorite by them...perhaps they're just waiting for me to get my settings configured properly so that they can actually download the files lol i don't know...I'll go ahead and upgrade, just to stay in the game, and keep my fingers crossed that somewhere down the line, Tribler becomes a little bit more newbie-friendly and the kinks and whatnot get worked out. I do hope that at some point there will be easy to understand instructions/tutorials as Tribler is improved upon and more people get involved in it's use. But I guess for me, uTorrent will have to do.

Thanks for all the help :-)
"This one time, at band camp..."
User avatar
susie
Visitor
 
Posts: 23
Joined: Tue Feb 14, 2012 8:25 pm
Location: California

Re: Downloading/Seeding?

Postby Uffowich » Tue Feb 21, 2012 11:05 am

If you're behind a hardware FW or router, you still need to open up those ports there, if it's not supporting UPNP which should open them automatically. Normally you do this by going to your gateway-address using your browser.
Uffowich
Visitor
 
Posts: 78
Joined: Mon Feb 13, 2012 10:40 am

Re: Downloading/Seeding?

Postby Niels » Tue Feb 21, 2012 11:09 am

Just recently we added 2 new team members who are trying to improve the usability of the ui.
They are now in the process of investigating all the different 'flows' in the ui and next are going to try to optimize them.
When they're finished we should build/create some tutorials explaining new users how to do stuff in Tribler and explain some features.

Thanks for trying and stay tuned for updates :P
Niels
Addict
 
Posts: 718
Joined: Mon Aug 23, 2010 1:56 pm

Re: Downloading/Seeding?

Postby susie » Tue Feb 21, 2012 6:49 pm

Uffowich wrote:If you're behind a hardware FW or router, you still need to open up those ports there, if it's not supporting UPNP which should open them automatically. Normally you do this by going to your gateway-address using your browser.


I'm sorry, Uffowich, I don't understand. I'm using windows 7 firewall, and allowed tribler through, and as for the router, i went through all the steps at portforward.com that were listed for my router. Are you saying there is more I can/should do to try to get tribler to work for me? Perhaps you can step-by-step- me through what it is? I don't know what is or isn't support UPNP, and I don't know what UPNP is :-( If you don't mind, I'm happy to follow your instructions, if you wanna lay 'em out for me :-)
"This one time, at band camp..."
User avatar
susie
Visitor
 
Posts: 23
Joined: Tue Feb 14, 2012 8:25 pm
Location: California

Re: Downloading/Seeding?

Postby Migratory » Tue Feb 21, 2012 11:47 pm

Uffowich Is referring to a physical firewall, which is a small router-like device between your router and modem. You probably don't have one, but if you do, tell us and we can help you with it.

UPnP stands for Universal Plug 'n Play, which is a software thing some routers have. It is not required for Tribler.

Also, what ISP (Internet Service Provider) are you using? That could be related somehow.

Finally, have you managed to upload anything at all?
Migratory
Visitor
 
Posts: 6
Joined: Mon Feb 20, 2012 9:14 pm

Re: Downloading/Seeding?

Postby susie » Wed Feb 22, 2012 1:16 am

Hi Migratory,

My ISP is Surewest, I've not normally had issues with them regarding the stuff I do on my computer, like blocking things and whatnot, so I am unsure if that would be a problem now.

As for uploading, I don't *think* that I have uploaded a single thing to anyone, but I'm not exactly sure how to confirm this. Under the "manage torrents" tab of my channel, it shows that my created torrents have completed d/l, are seeding, with 0 activity. Along the bottom is shows sharing rep: poor, 152MD down, 0 up; and the far right bottom corner it shows a gray smiley face (port status unknown), and a gray monitor (opening firewall (if any) via UPnP).

I've no clue what all that means lol but maybe it will help y'all help me :-) I have also upgraded to the .13 version as well.

I've noticed that Tribler is *extremely* slow to respond when I click tabs and channels and such...a good few seconds before it attempts to respond and I always get that "not responding" message in between...quite frustrating in it's own right lol

Thanks again for any help.
"This one time, at band camp..."
User avatar
susie
Visitor
 
Posts: 23
Joined: Tue Feb 14, 2012 8:25 pm
Location: California

Re: Downloading/Seeding?

Postby Migratory » Wed Feb 22, 2012 2:02 am

The "0 up" does in fact mean that you have not uploaded anything.

That slow response from Tribler is unusual... Even on my worst computer it runs fine. Anyway, I think that message from the monitor is helpful. It's saying that it's trying (and likely failing) to use UPnP to open a port in your firewall. I take it that you are not using a hardware firewall, right? Some routers have firewall capabilities, yours might be one of them. What brand and model do you have?
Migratory
Visitor
 
Posts: 6
Joined: Mon Feb 20, 2012 9:14 pm

Re: Downloading/Seeding?

Postby susie » Wed Feb 22, 2012 2:31 am

Hi Migratory,

I am using a Linksys Wireless WRT54G. We went into the router ip address and disabled the firewall and unticked the "block anonymous internet requests" box. We downloaded and installed PFConfig's program that automatically sets up a static ip, and then we purchased PFConfig's program that automatically does the port forwarding stuff for you. Everything worked as it said it should. Tribler has been allowed through my Windows 7 firewall.

Rebooting the computer, I opened Tribler, and I still have a gray smiley face along the bottom, as well as a gray monitor.

I was really hoping things would work after buying that PFConfig program, dammit! Now I feel like we just wasted $30 :-(

I don't know what else to do....

oh..and it's response speed is *somewhat* better, but still quite slow and laggy.
"This one time, at band camp..."
User avatar
susie
Visitor
 
Posts: 23
Joined: Tue Feb 14, 2012 8:25 pm
Location: California

Re: Downloading/Seeding?

Postby Migratory » Wed Feb 22, 2012 2:46 am

Has the message from the monitor icon changed?
Migratory
Visitor
 
Posts: 6
Joined: Mon Feb 20, 2012 9:14 pm

Next

Return to General

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron